[Bonus Plugin] Commodity Logistics Software MK2

The place to discuss scripting and game modifications for X³: Reunion.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Posts: 17461
Joined: Sat, 23. Apr 05, 21:42

Post by jlehtone » Wed, 13. Sep 06, 17:11

I have not seen it discussed elsewhere, but there was similar note in unsigned Station Manager thread, IIRC. Somebody noticed the same behaviour in that script.

And the number of asteroids still limits you, like always. :wink:

Butch Coolidge
Posts: 15
Joined: Fri, 3. Jun 05, 21:11

Post by Butch Coolidge » Wed, 13. Sep 06, 21:06

And the number of asteroids still limits you, like always.
That's true of course. But it surprised me that the script has been signed although it behaves like this. Looks like nobody noticed this behaviour before.

Posts: 103
Joined: Fri, 14. Apr 06, 10:26

Post by angels7707 » Sat, 16. Sep 06, 14:12

another noob question... if the minimum set price for the ware is not met .. does the TS just wait at the factory???
Forever Young

Posts: 12
Joined: Fri, 8. Sep 06, 11:27

CLS MK2 problem

Post by fiktik » Thu, 26. Oct 06, 21:47

Greetings, have been redirected here with my problem.

My situation: I need to transport ECells from my spacefuel complex to silicon mine and get silicon back to the complex (both being at Omicron Lyrae)

I'm trying to start CLS MK2 on my Mercury having this onboard:
3x25MJ shields
Fight Com Soft MK1
Nav Com Soft MK1
Boost Ext

The ship is docked at EQ dock in OL with no orders, this is what I do:
- in additional ship commands I choose Add/Change interm. stops
- first input is 0 to add new command
- then universe map appears to select (as I get it) some waypoint along the way - I select the spacefuel complex
- then universe map appears again to select destination - I select the spacefuel complex once more
- then there is list of all wares at the complex, I select ECells
- then I input 0 as I don't want any credits to be charged
- then I input the amount of ECells I want to be loaded (I want to transport as much as I can to match the 'price' of silicon then transfered back), so i write 3960
(tried to set different values there, even tried the add 100000 to needed amount to match it in cargo bay feat, with the same result)

And thats when a buzzing noise sounds as if something bad happened. Now when I let the ship send me the list of orders there is no sign of any. Theres the line Intermediate stops: (4) and under it just total flight time etc.
Obviously if I then command the ship to Start external commodity logistics, it just sits there and do nothing.

I also tried to go the other way round ordering it first to pick up silicon ... the same thing happens.

That's in X3 1.4.03 with BP 3.1.04 btw.

Steve J.
Posts: 159
Joined: Sat, 8. May 04, 06:05

Post by Steve J. » Thu, 26. Oct 06, 22:24

I had the same problem. Setting a home base for the ship seems to have fixed it.

Posts: 12
Joined: Fri, 8. Sep 06, 11:27

Post by fiktik » Thu, 26. Oct 06, 22:41

Oh you're right, setting homebase sorted it out. Thanks alot!

Posts: 17461
Joined: Sat, 23. Apr 05, 21:42

Post by jlehtone » Fri, 27. Oct 06, 08:45

After a sleep, I would have suggested a homebase too. It may only be necessary for the price=0 situation. That is "Load"/"Unload", while any other price is "Buy"/"Sell".

Posts: 49
Joined: Mon, 15. Nov 04, 04:38

Not using TL

Post by Chieftonw » Tue, 21. Nov 06, 00:23

I am having the same problem mentioned earlier, although no resolution appears to have been posted. Basically I have a MK2 (Courier rank, from Herron). I have set it up to pickup wares from my complex and unload them at a TL in the same system. It has all the required upgrades, as well as the transporter device. However it just loads the wares and goes in to stand-by. After that it just sits at the station doing nothing, although it looks like it will load more wares over time. It just never unloads them at the TL. Is there something I am missing or should check to fix this problem?

Posts: 17461
Joined: Sat, 23. Apr 05, 21:42

Post by jlehtone » Tue, 21. Nov 06, 09:49

Actually, there is a minor bug. I had the same problem, TS (CLS Mk1), Herron, and TL. So I contacted Lucike and sent him my savegame. But my TS had no Transporter Device. :oops:

However, apart from revealing how sloppy I am, Lucike spotted the bug. Both CLS1 and CLS2 use the same piece of code, so they share the transporter implementation and the bug:

The transportation works only if the player ship is in the sector.

Lucike has already fixed it for the unsigned (development) version, but naturally the signed version has to wait until the next version of the bonuspack is ready. There are changes due to 2.0, other fixes, and translation of some new stuff that all hold the next release.

My workaround to this bug is to use Teladi Falcon Haulers. They can dock into the TL.

Posts: 49
Joined: Mon, 15. Nov 04, 04:38

Thanks for the idea

Post by Chieftonw » Tue, 21. Nov 06, 10:33

Thanks for getting back to me. That explains both of my problems. I had originally tried the MK1 for my needs, but since it did not work I used the MK2. I will have to try the falcon, which should meet my needs. Thanks for the idea.

I was wondering if there a drop all wares command with the MK2? I am collecting several wares from my stations and would like to just dump them all in to my TL. But I am having to issue an unload of each item one by one.

BTW, I really wanted to thank you for these great scripts. They have made the game a lot more fun and effecient. When I first started playing X3, I almost was pulling my hair out trying to using the in-game transports.

Posts: 17461
Joined: Sat, 23. Apr 05, 21:42

Re: Thanks for the idea

Post by jlehtone » Tue, 21. Nov 06, 10:55

Chieftonw wrote:I was wondering if there a drop all wares command with the MK2?
No, there is not. One has to add separate waypoints for each ware. But one can have all load waypoints at the complex and then all unload waypoints at the TL. That way the ship flies less. Naturally, Falcon can haul only a limited amount. Therefore, CLS M1 is better in that use. It chooses what to haul and "dumps all" at the destination.

Posts: 13
Joined: Fri, 25. Aug 06, 01:53

Post by DeoLanDee » Sat, 25. Nov 06, 16:36

so its not possible to get your ships to make runs between your own stations :/?

- atleast I have tons of problems with it, as till now ive only got 2 of my ships to run between my own stations collecting wares, though the rest im trying to set up just wont move out of the place, they keep being on standby :/

User avatar
Posts: 96
Joined: Sun, 20. Jun 04, 01:57

Post by dazzoefc77 » Wed, 13. Dec 06, 20:40

First of all the package is great, the community has done itself proud.

Now for my problem. Using the External Commodities Mk 2 to collect Silicon from Mines of Fortune. And deliver to my HQ in Elisium.

1 Buy 700 silicion @ 450cr from Roid Alpha in Mines of Fortune
2 Sell 700 silicon @ 500cr to HQ in Elisium
3 Buy 700 silicon @ 450cr from Roid Bravo in Mines of Fortune
4 Sell 700 silicon @ 500cr to HQ in Elisium.

NOw i have already trained him up with minor jobs in Elisium so he is now jump capable (Freight pilot 1) and fully kitted out including e cells.

He will jump to point 1 from Elisium collect his silica and then fly home the long way (through Xenon sector 472) Should he not jump back to Elisium as he does have enough fuel? Or is he taking advantage of getting payed by the mizura. IS there a limit to how many jumps can be made in a tour?

Any one else having this problem? Is there anything i can do?
No silly Teladi i dont lose profit, I get your ship

Posts: 323
Joined: Sat, 18. Feb 06, 23:53

Post by UnderLord » Thu, 14. Dec 06, 16:04

I seem ot be having a bad problem none of my MK2 people want to trade i set the price for them to buy 5000 e-cells but they won't do anything! i cannot figure this damn thing out can someone break it down for me.....if i tell them to buy 5000 e-cells set a home base it says

"Buying 5000 e-cells" (from homebase) even though i want it to buy from a diffrent point and then if i tell it to drop off 5000 e-cells it gives me the bad beep and if i reverse it....it dosnt work.....

Reverse it means if i set it to buy (or attempt to) from the power plant and to drop it off at the homebase it gives me the bad beep.....s ono matter hwta i do the damn trader dosnt want to work....
Asus M4A785TD-V EVO
AMD Phenom II X2 550 @ 3100 MHz
4 x 2048 DDR3-SDRAM

User avatar
Posts: 264
Joined: Wed, 23. Nov 05, 01:30

Post by Mobuj » Sat, 16. Dec 06, 00:08

As far as I know, for the mk2 software, you have to spell out everything. The pilot will not refuel on his own. You program all actions. You also have to tell him to evade enemy attacks when they happen as I recall.

BTW, why do you use the price option, bookkeeping?
I am Popeye of Borg
You will be askimilated!

Post Reply

Return to “X³: Reunion - Scripts and Modding”