X Plugin Manager and SPK Tools for Mac v. 1.21 and AP Bonus Pack How-To (5/4/2012)

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Posts: 8
Joined: Sat, 4. Apr 15, 02:00

Post by boozehagskibum » Tue, 7. Apr 15, 01:04

Is it an issue with Yosemite then?
I thought it was an issue with the 3.2 update for Mac...
I can get PM to work but it when I get into the game none of the mods are there...

UPDATE!!! and good news!

Figured out the problem after a few hours...!

After running Cycrow's package in PM I found that the scripts copied into this folder:

These didn't work...
That was when, after some digging, I found another scripts folder in the actual app package (right-click on the app and click on show package contents) in the resources folder.
I copied and pasted all the cycrow scripts into this folder and - wahay!!!!

However, there is one minor issue.....
The main script relating to what you can do in the command console comes up as gobbledegook so when you click on option 3 (custom) you get garbled nonsense.
BUT....if you click on each of the garbled nonsense bits they still direct you to the particular cheat - wares, weapons, god mode etc

Hope this helps!

Posts: 1
Joined: Tue, 18. Oct 16, 23:56

Post by spasticgremlin » Wed, 19. Oct 16, 00:29

How is everyone.

I've been having a problem getting this X plugin manager thing to work. I downloaded the file and changeed my permissions to allow everyone. I have no "data" file however and I don't remember how I even bought the game originally (I think the app store a bunch of years ago).

My files paths are as follows for AP: "X3 - Albion prelude ML" (the executable) --> "Contents" --> 7 folders "_CodeSignature" , "_MASReceipt" , "Frameworks" , "Info.Plist" , "MacOS" , "PkInfo" and "Resources." Within "Resources", there are various folder to include the "addon" , "Documents" and "scripts" and now currently the exe's from the download. I've tried putting both of the .exe files in various spots but nothing seems to work.

Have used this program in the past but an automatic update on both TC and AP occurred the other day and the old plugin manager didn't work anymore and so I downloaded the new version. At first I was getting a "failed to activate core devices" then I received a can't update "Info.plist" (after which I changed those permissions as well.) Now the problem I'm getting is ""%@" can't be found." I'm no everyday modder or even an occasional modder so if theres a stupid answer that most people would have already tried than I might have missed it.

Posts: 3
Joined: Sun, 30. Mar 14, 15:27

Post by bf3qp9k » Wed, 19. Oct 16, 15:20

I have the Mac client for Steam, and X3: Reunion for the Mac through Steam. i would like to use the Plugin Manager for the Mac, to use with mods like Roguey's Mod or the Cheats 1.4 one.

I have downloaded and unzipped the plugin manager for the mac, and have no idea where to put the folder. It has an app in the folder, and I assume that goes in the Applications folder, but I have no idea where all the other folders are that this thread talks about. I can't find where Steam has installed X3, even.

Any pointers or help would be greatly appreciated ...

Posts: 4
Joined: Tue, 23. Apr 13, 17:32

Post by nickdyer2000 » Sun, 13. Nov 16, 23:47

not work for me anymore, keeps crashing with a wineskinx11 error.

any ideas?

Posts: 6
Joined: Fri, 2. Dec 16, 20:43

i have a small problem...

Post by LoganWolf » Fri, 2. Dec 16, 21:30

First off, i'm sorry for posting this here like this, but for some reason the platform won't let me post a reply in the concerning post. < Merged. Try clearing your browser cache. AP> Anyway, here it goes.

The plugin manager for mac... So I bought X3 Terran Pack from GOG a while ago and so far I'm loving TC and can't wait to try AP. Then I found this forum with all these mods and awesome upgrades that now I can't wait to binge on it. However there is no Data file in the GOG install (inside its package or either package for TC or AP) and I don't know where to copy the dummy .exe files to so that the PM can recognize the games...

Again sorry for this post, I know it's a noob move, but I didn't know what else to do since it wouldn't let me reply on the post for the PM-MAC.

Thanks for the help and keep up the awesome work. :)
make sh*t happen.

Posts: 10
Joined: Tue, 9. Mar 10, 17:54

Post by james_tom » Sun, 5. Feb 17, 13:02

I may need some help here. The program can not start and reports errors of" Can not initialize core devices".

Any clues to resolve this problem?

My mac is OS X 10.11.6 EI Capitan.

Posts: 10
Joined: Tue, 9. Mar 10, 17:54

Post by james_tom » Sun, 5. Feb 17, 13:04

nickdyer2000 wrote:not work for me anymore, keeps crashing with a wineskinx11 error.

any ideas?
Same issue here. Any ways to resolve this?

User avatar
Posts: 440
Joined: Mon, 27. Feb 06, 19:30

Post by Chemical-mix » Tue, 14. Feb 17, 00:18

Hi All,

I've just tried to download Cycrow's plug-in manager, but once it has finished downloading, clicking on the shortcut causes explorer to try and open from a completely different filepath.

Whenever i manually navigate to the Plug-in manager folder, all it contains is empty folders, regardless of what package options i choose to install, including "full"install. Never seen this before, it's worked on all my other PCs/laptops.

Uninstalling/reinstall doesn't help.

Any ideas?
"I came, I saw, I crumbled"

Posts: 1
Joined: Sat, 21. Oct 17, 10:37

problem with the mod manager.

Post by Edgelordx666 » Sat, 21. Oct 17, 10:53

hay I have a problem with the mac mod manager.

when I open the mod manager it says

ERROR! cannot write to Info.plist, there are permission problems, or you are on a read-only volume. This cannot run from within a read-only dmg file

does anyone have any idea how to fix this

Posts: 4
Joined: Sat, 13. Jan 18, 10:52

Post by davidphd » Sat, 13. Jan 18, 11:06

The biggest problem is, there is no "data" file in the content folder. Because there is no alternative selection about where to place these files (usually the app file stays in the application folder--it doesn't work there) but I get the impression from the post to place every thing in the "data" folder. Which doesn't make sense. I have TWO folders for scripts and TWO t folders, which look like a scripts folder of some kind. Secondly, the files downloaded are .exe files. These files are normally run on a PC and not a Mac. Without a Wineskin app of some kind to open them, they are basically useless. I like that this forum exists, but unless this thread is to see how foolish we are, I can't see that it is a big waste of time--but I trust that isn't the purpose, so can somebody please fill in what I missed, in detail. Thank you. PS. the vanilla game is great. I did figure out to script money, so no biggy if this isn't answered, but I was hoping to download Trek ships. Thanks. ALSO, my game was downloaded from the APP Store and is not from Steam.
There ought to be laws for robots...

Posts: 4
Joined: Sat, 13. Jan 18, 10:52

Post by davidphd » Wed, 17. Jan 18, 09:00

For those of you having difficulties finding that unwonted data file in Mac's High Sierra, it is here on my Mac: SDD001 (my main drive) users/account1 (my user account name) /Library/Containers/com.vpltd.X3AP-MAS/Data. Took me an hour to locate it. It cannot be found by just looking in the 'Library'. It might be different on your machine, so take a few deep breath, get yourself a cup of mocha, and go through every file if you can't find it. As an alternative, you might try searching for X3AP-MAS. For some reason just plain X3 didn't work for me. Yes, it is com.vlptd.X3AP-MAS. ALSO--many save files are found in the the content file (right click on the app and view contents) but X3 saves are not kept there, so don't bother. Good luck.

ASK is the acronym for Ask, and you shall receive, seek, and you shall find, knock, and it shall be open for you.
There ought to be laws for robots...

Posts: 1
Joined: Tue, 26. Jun 18, 20:24

Post by captainfrost20 » Tue, 26. Jun 18, 20:30

Does this work with the steam version? I keep getting this when I execute the Plugin Manager.
"ERROR! Cannot write to info.plst, there are permission problems, or you are on a read only volume

This cannot run with a read-only dmg.file"

Posts: 1
Joined: Wed, 26. Aug 15, 00:51

Post by James_Purcell » Wed, 5. Sep 18, 21:22

I launch the plug in manager and I get:

"ERROR! cannot write to Info.plist, there are permission problems, or you are on a read-only volume.

This cannot run from within a read-only dmg file."

I'm using the STEAM version of the game, where there is NO data folder in the latest version, making the information on the front page not relevant.

Can anyone help me get this plug in manager working?

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”