[EMP]Extended Mod Pack (2.7 compatible) [Not needed for latest Plugin Manager]

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Post Reply
Tacticalhl
Posts: 32
Joined: Tue, 27. Dec 11, 03:25

Post by Tacticalhl » Mon, 23. Jan 12, 06:19

Main link is down I hope this 1.4 alt link is alright. I would also suggest putting the hot fix on the first page.

Tacticalhl

FishBone_B
Posts: 16
Joined: Tue, 8. Sep 09, 14:18
x4

Post by FishBone_B » Wed, 7. Mar 12, 15:23

Does anyone have a link to the latest version? Link in OP is down..
I've been looking around the net for several days and not found an alternate link..

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20606
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Wed, 7. Mar 12, 16:40

the latest version is built into the plugin manager and its generated automatically based on your current wares files

so works for both TC and AP

FishBone_B
Posts: 16
Joined: Tue, 8. Sep 09, 14:18
x4

Post by FishBone_B » Wed, 7. Mar 12, 17:08

Hmm, because I just ran into an annoying problem.

I got into my head to try and play a vanilla game, so used the plugin manager and set mode=vanilla.

When that was too boring, I reverted back to mode=modified.

Problem is, after doing that, a load of wares changed name to
ZA_EMP_<numbers>.

Ones I've ID'd so far are Supply, Patrol and Explorer software, Figher drones MKII, Salvage Claim Software, ect.

I don't really know anything about scripting, but it seems I broke some links somewhere.

Any way I could fix this? Any more info I can supply?

I updated to the last version of X Plugin Manager, tried DL'ing more up to date mods.. nothing.

I even tried restoring a backup of my game I made mid 2010 when I had just finished modding it -> same result. Mind you, this was a steam-backup, so probably worth nothing ^^

Any help would be greatly appreciated. Been playing these saves for 3 years almost, would hate to see them unplayable..


Schabernack
Posts: 215
Joined: Wed, 18. Apr 07, 19:32

Post by Schabernack » Sat, 18. Aug 12, 19:39

@Cycrow
so i just installed the plugin manager 1.47. The packages which are already installed, the EMP isn't mentioned. Do i need to install it or is it only not shown.
Earlier you mentioned it would be included, but i'm not quite sure now.
learn from the past, live the moment, dream of the future
tc-ap minimax

User avatar
vukica
Posts: 1388
Joined: Sun, 10. Aug 08, 18:05
x4

Post by vukica » Sat, 18. Aug 12, 21:16

Schabernack wrote:@Cycrow
so i just installed the plugin manager 1.47. The packages which are already installed, the EMP isn't mentioned. Do i need to install it or is it only not shown.
Earlier you mentioned it would be included, but i'm not quite sure now.
it's included.
Split say NEED MORE FIREPOWER!!

Schabernack
Posts: 215
Joined: Wed, 18. Apr 07, 19:32

Post by Schabernack » Sun, 19. Aug 12, 20:15

thx for confirmation vukica
learn from the past, live the moment, dream of the future
tc-ap minimax

spoidz
Posts: 607
Joined: Sat, 6. Mar 04, 21:43
x3tc

Post by spoidz » Tue, 11. Sep 12, 19:39

I've still got a bunch of ZA_EMP_BLANK_WARE_CUSTOM in my game and I want to troubleshoot but I can't seem to find a list of what mods have used which ones so far.

The Script/MOD list sticky only lists the SS_ware list.

Is there a master list link anywhere that has kept up with who is using which wares so far?

Thanks

Chaney08
Posts: 3
Joined: Sat, 1. Dec 12, 15:11
x3tc

Post by Chaney08 » Sat, 1. Dec 12, 15:22

Hey guys, sorry to revive an old thread but only recently introduced to this game and its damn awesome. Anyway wanted some mods and I got Complex Cleaner mod as well as Cycrows multiscript mod. I have EMP 2.01 installed and the 37 mods that comes with Cycrows mod.

Anyway the problem I am having that I cannot seem to fix is the fact that my Fighter MKII factory is not coming up correctly. It shows it is creating MKII fighters but the factory name is ZA_EMP_BLANK_WARE_CUSTOM10_2. Now this would not be a major problem but it is extrememly annoying as it is making the complex it is built into flash yellow all the time despite me having the resources to fuel it. Any help is greatly appreciated. Sorry again for dragging up an old thread but cannot seem to find a solution to this.

EDIT: This happens on all software as well.

User avatar
LV
Sith Lord
Posts: 6362
Joined: Wed, 6. Nov 02, 21:31
x3tc

Post by LV » Sat, 1. Dec 12, 18:00

http://x3tcscripts.googlecode.com/files ... pdater.zip

try this. no idea if it will work as its a long time ago in a galaxy................

run manually, if it does not work delete the script and reload
LV's TC Scripts
Readme's For All My Scripts


I felt a great disturbance in the forum, Like millions of voices cried out in terror, then were silenced

si tacuisses, philosophus mansisses

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Sun, 2. Dec 12, 00:31

Chaney08 wrote:I have EMP 2.01 installed
Where did you get EMP 2.01? That sounds like an old version to me.

EMP is built into the Plugin Manager. I have had the best luck with removing EMP mods completely, then open and close the Plugin Manager to get it to rebuild EMP-aware files. The PM will not do the job correctly if you have a version of EMP installed, because the PM assumes that you know what you are doing. ;)

Also, be aware that some scripts that use EMP use an outdated version and will not work without modification with current versions of EMP. If you need to debug after doing the above, then list the scripts you have installed and the exact text of the errors.

Chaney08
Posts: 3
Joined: Sat, 1. Dec 12, 15:11
x3tc

Post by Chaney08 » Sun, 2. Dec 12, 17:47

Hi LV and DrBullwinkle, thanks for the reply, I downloaded the plugin manager from http://cycrow.thexuniverse.us/ and the EMP mod was already installed on it. Also LV where do I stick that file? Sorry for stupid question, just do not know correct foder, I am using Albion Prelude if that matters.

Thanks guys.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Sun, 2. Dec 12, 17:53

You are using out-of-date stuff, Chaney.

Get the current Plugin Manager from the sticky thread at the top of this forum. Remove any other EMP installation that you have installed. Then open and close the Plugin Manager. You do not need the script that LV linked if you have the current PM.

Chaney08
Posts: 3
Joined: Sat, 1. Dec 12, 15:11
x3tc

Post by Chaney08 » Sun, 2. Dec 12, 18:17

Thanks DrBullwinkle, I just googled the plugin manager and that was top result which is why I have it lol. I shall do that now! Thanks again!

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”