[EMP]Extended Mod Pack (2.7 compatible) [Not needed for latest Plugin Manager]

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
Requiemfang
Posts: 3197
Joined: Thu, 16. Jul 09, 12:24
x4

What script uses this?

Post by Requiemfang » Tue, 17. Aug 10, 13:32

I was in boron space and I saw this while docked for the wares that your able to buy... what script/mod uses this slot for the ware at the bottom?

I know it's a mod/script that uses the EMP, and the EMP already is installed via the plugin manager cause it automatically comes with it when it installs

Image


{Merged to the EMP thread, because the answer could/should be there. jlehtone}

diginess
Posts: 6
Joined: Thu, 19. Aug 10, 05:36
x3tc

Hmmm

Post by diginess » Sun, 12. Sep 10, 02:48

Well, I too am getting all kinds of those EMP related item names. Now I have no idea what items they are, and in order to keep playing the game, I have to fix it somehow. I may have to reinstall from scratch, don't know yet.
Currently have 5 of them in my cargo hold, and when I scan other ships, sometimes they show up there too.
I tried downloading LV's xml / script updates from the folder he linked to, but even after re-initing the scripts, it didn't change the ZA_EMP item names.
I also tried updating to the beta X-Plugin manager lite version, but that didn't help.
Would removing EMP resolve the issue, and if so, how is that done?

Thanks.

diginess
Posts: 6
Joined: Thu, 19. Aug 10, 05:36
x3tc

Further reading

Post by diginess » Sun, 12. Sep 10, 03:00

OK, I've read so far that EMP is used to create new items for scripters, and on this thread:
http://forum.egosoft.com/viewtopic.php? ... 13#2606713
it looks like there's a code page which includes the exact item names that I'm seeing. The only problem is that I have no idea now which script uses those items or what they do. I tried disabling what I thought would be the relevant scripts in the plugin manager, but of course that didn't work...
Maybe if there's no way to uninstall EMP I can find the latest version and install that over the top?

diginess
Posts: 6
Joined: Thu, 19. Aug 10, 05:36
x3tc

Last post

Post by diginess » Sun, 12. Sep 10, 03:11

Last post guys, sorry.
These are the ZA item names I'm getting:

ZA_EMP_BLANK_WARE_CUSTOM10_2
ZA_EMP_10053_WARE_CUSTOM1_1_999992cr
ZA_EMP_10073_WARE_CUSTOM3_1_392cr
ZA_EMP_10073_WARE_CUSTOM4_1_1568cr
ZA_EMP_BLANK_WARE_CUSTOM4_2

Do those look familiar?

diginess
Posts: 6
Joined: Thu, 19. Aug 10, 05:36
x3tc

Got it

Post by diginess » Sun, 12. Sep 10, 03:23

For all the people using EMP and the latest version of the game having problems with the ZA_EMP blank item names showing up after installing new item scripts and the like - download the latest version of EMP:

http://www.after-domination.net/phpbb3/ ... p=274#p274

extract it to your X3TC game folder, and rename those two files (just look at the two file names that say rename, you'll know what to do).
It works for me now. Note: I have the version 2.7 of the game, they said something about this version of EMP being updated for 2.7.

Spectral Doom
Posts: 5
Joined: Mon, 8. Sep 08, 15:22
x3tc

Post by Spectral Doom » Sun, 19. Sep 10, 17:17

Hi,

I'm using the updated version of EMP 2.7 as per the instructions by diginess and yet I'm still getting ZA_EMP issues.

The problem occurs in a recently terra formed sector by Imperial Laboratories. Station details appearing are -

ZA_EMP_13433_ BLANK_WARE_CUSTOM19_17 Laboratory

Ware details are -

ZA_EMP_BLANK_WARE_CUSTOM11_10
ZA_EMP_BLANK_WARE_CUSTOM19_17

Don't know if this is more a question for LV regarding his IL Plugin or more pertinent for the EMP discussion??? I'm only just starting TC so similar problems may appear in other unexplored sectors.

Strange thing is that 13433 doesn't even appear on the EMP used ware list offered right at the start.

Any help would be greatly appreciated as I'm at a loss for answers.

Thanks
Spectral Doom

Khaak_Slayer
Posts: 388
Joined: Sun, 18. Apr 04, 17:04
x4

Post by Khaak_Slayer » Tue, 4. Jan 11, 01:35

I'm getting ZA_EMP_BLANK_WARE_CUSTOM5_7

Everyone else seems to be posting theirs.

I'm also getting ReadText2010-530 on the Special commands page, it has description: [ReadText2011-530]

Not sure if they're related, I haven't been able to locate a solution for either, the ReadText entry isn't listed on the mod repository topic.
Rawr.

User avatar
LV
Sith Lord
Posts: 6362
Joined: Wed, 6. Nov 02, 21:31
x3tc

Post by LV » Tue, 4. Jan 11, 12:17

running this hotfix should cure the za stuff
http://x3tcscripts.googlecode.com/files ... pdater.zip

install the script and run manually via the ingame se with r,r,enter

530 is mobile ship repair by graxter, you'll need to ask about that problem in that thread
LV's TC Scripts
Readme's For All My Scripts


I felt a great disturbance in the forum, Like millions of voices cried out in terror, then were silenced

si tacuisses, philosophus mansisses

Khaak_Slayer
Posts: 388
Joined: Sun, 18. Apr 04, 17:04
x4

Post by Khaak_Slayer » Thu, 6. Jan 11, 00:47

That was a lot of help, your info helped me fix both problems, thanks.

I kept hearing "Removed" over and over, each several minutes apart, lasting for some time after installing that thing you linked, is that normal or related?
Rawr.

lastebil
Posts: 291
Joined: Sun, 6. Jan 08, 22:02
x3tc

Post by lastebil » Sun, 6. Mar 11, 12:34

I haven't tried the xtended mod yet, and don't know if I'm going to get the opportunity in the near future, but I want you guys to know you make a hard core nerds hearth warm! Thanks for keeping up the extremely good work.

User avatar
Vyruz
Posts: 329
Joined: Sun, 8. Oct 06, 21:57
x4

EMP slots/entry

Post by Vyruz » Wed, 6. Apr 11, 19:41

Hey ho, back on the keyboard...

i got myself terran conflict at the weekend and while my girle is pregnant and to escape her hell-ish hormone, i'll take the chance to fly in the universe :roll:

I installed a few scripts'n'mods from the site and super-box
and of course the EMP.

after a few hour flyin, a loot "ZA_EMP_BLANK_ware_custom_2" was flyin around

anyone know what script/mod is using that slot?

guess i didn't installed one correctly :(

I checked out the script & mod library, but couldn't find any thing about the EMP slots. (point me out if i'm mistakin and there is an index about what mods using what EMP slots)

c'ya


{This kind of questions seem frequent in the EMP thread, so I'll merge. jlehtone}

GrrlPower
Posts: 13
Joined: Mon, 13. Apr 09, 16:25

Problems with EMP,any assistance would be wonderful

Post by GrrlPower » Sun, 5. Jun 11, 02:16

I have the extended mod pack that is required for some of the mods available,but i have never really got it to work right. Every time i try to use it,i get certain wares that have had their names changed to "ReadText-(number)" and no longer have a discription. i am sure others have had the same issue,but am finding it hard to get any info in the "ReadText" error. I am playing version 3.1 right now,but ive always had issues with the EMP. Any ideas on how to get the thing working so i can use some of the mods i have that require it?


{[url=http://forum.egosoft.com/viewtopic.php?t=216696][b]T[/b][b]C[/b] [b]S[/b]&M Posting [b]R[/b]ules[/url] Rule #1. Learn it. Merged. jlehtone}

User avatar
EmperorJon
Posts: 7178
Joined: Mon, 29. Dec 08, 21:58
x3tc

Post by EmperorJon » Sun, 5. Jun 11, 14:57

This error means I can't read the text from the text file.
Make sure the corresponding number of text file is correctly in the T folder of the game.
______
I'm Jon. I'm mostly not around any more. If you want to talk, please message me! It's cool.
______

Mystra007
Posts: 12
Joined: Fri, 9. Dec 05, 04:02
x3

Post by Mystra007 » Tue, 12. Jul 11, 01:40

I'd like to reserve the following EMP-X wares for Guilds use pending Cycrow approval:
(as presented on the After Domination page):
Slot 03 Ware 24 Medium 58592cr ref: 61620
"Basic Cabin Space"
Slot 17 Ware 24 Medium 70020cr ref: 61760
"Normal Cabin Space"
Slot 07 Ware 28 X-Large 160704cr ref: 62460
"Luxury Cabin Space"
Slot 09 Ware 19 Small 14852cr ref: 60680
"Occupied Cabin Space"

Edit: Approval has been given

JjLeBeau
Posts: 1
Joined: Tue, 30. Aug 05, 20:48
x2

Post by JjLeBeau » Sat, 10. Sep 11, 08:03

Okay so i just restarted the games. My problem is that when i dock with equipment docks the advance jump drives wares turn to the zz emp blank yaadda yaddda, and stays that way. But if I go to an eEQ, I've never docked at b4 and use a ship I'm not flying to dock the wares show up as Advance jump drive and what not. I can work around this and just never personally dock and use other ships to dock only, and then tranport the wares over, but it's just confusing why the names of the wares disappear only when i dock.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”