[EMP]Extended Mod Pack (2.7 compatible) [Not needed for latest Plugin Manager]

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Post Reply
Retroman77
Posts: 5
Joined: Fri, 5. Feb 10, 01:08

Help! I can't get EMP to work!

Post by Retroman77 » Fri, 5. Feb 10, 01:19

I have been trying to figure this out for a few hours now, but I can't seem to get it to work. I cannot seem to get the extended mod package to work.

Is there anyone who can give me a comprehensive walk through on how to install this mod?


{[url=http://forum.egosoft.com/viewtopic.php?t=216696][b]T[/b][b]C[/b] [b]S[/b]&M Posting [b]R[/b]ules[/url]. Merge. jlehtone}

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20606
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 5. Feb 10, 01:28

what happens when you try to install it ?

and are you using the plugin manager at all ?

Retroman77
Posts: 5
Joined: Fri, 5. Feb 10, 01:08

Post by Retroman77 » Fri, 5. Feb 10, 01:45

Nothing happens. I install the mod, and none of the items from mods that require emp show up in game anywhere I can find. I am also using the script manager lite.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20606
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 5. Feb 10, 01:49

the plugin manager already includes EMP so you dont need to install it seperatly

and sometimes installing it seperatly can conflict and cause the text for wares to not appear correctly.

best way to check if its working is to use the cheat scripts, and goto Add Any Ware, at the bottom of that list you should have a load of blank emp entries

Retroman77
Posts: 5
Joined: Fri, 5. Feb 10, 01:08

Post by Retroman77 » Fri, 5. Feb 10, 02:28

I re-installed everything including x3, and purging the program files of everything x3. After re-booting everything except emp, I still cannot get the dependent mods to show up in game. What do you think is going wrong?

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20606
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 5. Feb 10, 11:57

Did you check the cheat scripts ware list to see if they appear
It will show all wares in the game
This would determine if the problem is emp or the other scripts

Retroman77
Posts: 5
Joined: Fri, 5. Feb 10, 01:08

Post by Retroman77 » Fri, 5. Feb 10, 21:30

There is nothing new in the cheat script menu.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20606
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 5. Feb 10, 23:33

then for what ever reason, EMP isn't being loaded.

are you using any mods that might be overrighting the files ?

also are you closing the plugin manager before running the game ?

and finally, does the types folder exist in your game directory, and is the file TWareT.pck in there ?

Retroman77
Posts: 5
Joined: Fri, 5. Feb 10, 01:08

Post by Retroman77 » Sat, 6. Feb 10, 00:55

I have loaded only only emp, and the cheat console but to no avail.

Also there is the TWareT.pck file in my types folder.

User avatar
DannyDSC
Posts: 6368
Joined: Sun, 5. Dec 04, 21:32
x4

Post by DannyDSC » Fri, 5. Mar 10, 17:15

EX Egosoft Translator

Cedric_FP
Posts: 173
Joined: Thu, 13. Apr 06, 17:56
x4

Emp 1.4 Spk

Post by Cedric_FP » Thu, 1. Apr 10, 10:27

NVM - saves were corrupted, unfortunately.

My own silly fault.

Note to self: don't disable random things for testing and not back up your saves.

Sorry to clog up the EMP thread.

User avatar
LV
Sith Lord
Posts: 6362
Joined: Wed, 6. Nov 02, 21:31
x3tc

Post by LV » Sun, 2. May 10, 10:47

I think i may have found the cause of the EMP text going back to ZA_


I was messing with tfiles to make myself a MD MKII and noticed all weapons that do not need ammo list the same EMP ware

Image

I do not mod so have no idea how to fix but I assume some of the more exp modders around here know how to

therefore i'm looking for someone to fix :)
LV's TC Scripts
Readme's For All My Scripts


I felt a great disturbance in the forum, Like millions of voices cried out in terror, then were silenced

si tacuisses, philosophus mansisses

DIGSIN
Posts: 395
Joined: Fri, 28. Oct 05, 12:37
x4

Post by DIGSIN » Tue, 8. Jun 10, 22:54

Update to 2.7 now, i have not fully tested it with scripts yet, so if you find any problems please post them.

@LV, the problem you found has now been rectified (i hope)

Vivicector
Posts: 158
Joined: Thu, 10. Jul 08, 09:10

Post by Vivicector » Wed, 9. Jun 10, 07:56

Can anybody make it clear... It is written in the readme, that there is a problem with installing new version of this mod as fake patch. What problem? Will it be fixed? Does it even exist right now or readme was just not refreshed?

DIGSIN
Posts: 395
Joined: Fri, 28. Oct 05, 12:37
x4

Post by DIGSIN » Wed, 9. Jun 10, 18:50

Vivicector wrote:Can anybody make it clear... It is written in the readme, that there is a problem with installing new version of this mod as fake patch. What problem? Will it be fixed? Does it even exist right now or readme was just not refreshed?
It should install ok, i havent updated the readme is all

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”