Joystick not recognized..

Ask here if you experience technical problems with X³: Terran Conflict, X³: Albion Prelude or X³: Farnham's Legacy.

Moderators: timon37, Moderators for English X Forum

Post Reply
Posts: 7
Joined: Tue, 29. Sep 15, 23:05

Joystick not recognized..

Post by fastesteddy13 » Tue, 7. Feb 23, 11:51

Hi all..

Apologies, I am sure this must have been covered, probably many times already.. But I have spent the past 10+ hours reading hundreds of posts all over the net, and still do not have a solution.

Am running Ubuntu 18.04, am using GOG Terran War Pack X3 (latest download) and I have a Microsoft Sidewinder Precision 2 joystick which works fully under jstest. My understanding is that X3 now uses SDL2 (evdev) and so I have been trying to find a way to configure it in a way that X3 will detect it. Currently it does not and no controllers are listed. I have tried 'sudo ln -s input/js0 /dev/js0' as suggested under the Linux support section, but it changes nothing for me.

I have /dev/input/js0 and also /dev/js0 so dont think that is the issue.

This game used to run flawlessly a couple of years ago, now I just cant seem to get this joystick to be detected and after the hundreds of posts I have read, there must be a huge number of folk out there with the same problem..

Any help please?

Posts: 7
Joined: Tue, 29. Sep 15, 23:05

Re: Joystick not recognized..

Post by fastesteddy13 » Fri, 24. Feb 23, 23:40

No responses..!

Was sooo determined to get this all going today, and I did..!!

It was NOT the fault of, or anything to do with the joystick.. I wont go into all the detail of how I got there, but I had some files missing!!
Firstly, 32bit support;

sudo dpkg --add-architecture i386

Then some further missing files;


(sudo apt-get install 'file')

Then finally, after getting errors about sound (I use a usb focusrite 2i4);

sudo apt-get install libasound2-plugins:i386

..and that was it! The joystick had to be configured as rudder and throttle were assigned the wrong way around, but the game ran sweet after that. I ran the game from a terminal opened up in the game folder (home/steve/GOG Games/X3 Terran War Pack/game/) with;


Hope this helps another soul that was as confused as me.. Time to play..!

Post Reply

Return to “X³: Terran Conflict / Albion Prelude / Farnham's Legacy - Technical Support”