Exscriptor - new external script editor

The place to discuss scripting and game modifications for X³: Reunion.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Gqqnbig
Posts: 66
Joined: Fri, 12. Jul 13, 14:08

Post by Gqqnbig » Thu, 22. Aug 13, 07:34

No, it happened when I pasted test in as well as typing text. It looks like your program is written in .net. .NET Framework should deal with international characters properly. As a .net programmer, I also fell weird.

You are so generous that suggest another editor to me. Thanks. I will try it then.

Gqqnbig
Posts: 66
Joined: Fri, 12. Jul 13, 14:08

Post by Gqqnbig » Fri, 23. Aug 13, 02:23

Can you release your source code? I can spend some time investigating the problem and probably making some improvement.

I will use C#, .NET 4.0.

Whimsy
Posts: 167
Joined: Mon, 9. Feb 04, 21:32
x3tc

Post by Whimsy » Tue, 27. Aug 13, 23:21

Gqqnbig wrote:Can you release your source code? I can spend some time investigating the problem and probably making some improvement.

I will use C#, .NET 4.0.
I'll see what I can arrange. If you do figure it out though, let me know! :)

Gqqnbig
Posts: 66
Joined: Fri, 12. Jul 13, 14:08

Post by Gqqnbig » Wed, 28. Aug 13, 04:36

I think I've identified the problem. SynchronisedScrollBox works well with Chinese but at the level of ScriptingBox, Chinese cannot show correctly.

Code: Select all

	_Header = @"{\rtf1\ansi\" + _codePage + @"\deff0\deflang1033";
			_Header += @"{\fonttbl{\f0\fnil\fcharset0 Courier New;}}"; // Font table - just Courier
			_Header += @"{\colortbl ;";
			_Header += @"\red255\green255\blue255;";			// WHITE	(commands, normal)
			_Header += @"\red0\green255\blue0;";				// GREEN	(variables, constants)
			_Header += @"\red0\green128\blue255;";				// BLUE		(strings, numbers)
			_Header += @"\red255\green255\blue0;";				// YELLOW	(literals)
			_Header += @"\red255\green0\blue0;";				// RED		(errors)
			_Header += @"\red128\green128\blue128;";			// GREY		(comments)
			_Header += "}";
I'm not familiar with rtf but I think directly control of rft may be error-prone. Besides, your codepage is only 1252 and 1250.

I searched several websites. Some append "\deflangfe2052" after "\deflang1033'.

If I were you, I will not directly control rtf. Instead, I will use the methods and properties of RichTextBox and in case the methods and properties are not powerful or convenient enough, I will seek syntax hilighting control. There are some on the Internet for free, for example Fast Colored TextBox for Syntax (shows line number as well) and ColorCode - Syntax Highlighting/Colorization for .NET

TheHutt
Posts: 17
Joined: Mon, 4. Jun 07, 10:44

Post by TheHutt » Fri, 4. Oct 13, 20:07

This could be out of order but the 'search' isn't helping.

Just found this tool - been using exscriptor - like this tool a lot so far but can it load 'custom' page data i.e. the text descriptors.

I have one or two mods that I put descriptors into a file 449001, page id 17 but X-Studio doesn't load them along with the game data so all my 'custom' ships etc are missing all their text in scripts.

Short of reading 37 pages of thread is there a simple way to fix this - I know I'm dumb so no need to point it out thanks.

If I could edit ships etc in this tool I will have found X3 utopia ...

Whimsy
Posts: 167
Joined: Mon, 9. Feb 04, 21:32
x3tc

Post by Whimsy » Sat, 5. Oct 13, 00:10

TheHutt wrote:Just found this tool - been using exscriptor - like this tool a lot so far but can it load 'custom' page data i.e. the text descriptors.

I have one or two mods that I put descriptors into a file 449001, page id 17 but X-Studio doesn't load them along with the game data so all my 'custom' ships etc are missing all their text in scripts.
Yes, it should load any extra text from the language files (440001.xml etc). However, you don't say which game version you're using; for it to load properly, the name needs to be in the right format for the game version:
  • - For X2 and X3:R, it should be a two-digit language code (44=English) then a four-digit identifier, e.g. 441234.xml

    - For X3:TC and X3:AP, it should be the four-digit identifier first, then "-L0" (that's a zero), then the language code, e.g. 1234-L044.xml.
Exscriptor won't load 441234 style files when it's in TC/AP mode and vice versa. You'll also want to make sure the right language and game version are selected inside Exscriptor. But other than making sure the name is right, it should just load automatically; you should be able to double check by going into Tools->Conflict Viewer and then looking in e.g. page 17 to see if your new text appears there too. :)

Note that if the text file corresponds to a mod .cat/.dat, you'll probably need to set up the path to the mod .cat/.dat in the options as well.

TheHutt
Posts: 17
Joined: Mon, 4. Jun 07, 10:44

Post by TheHutt » Sat, 5. Oct 13, 00:20

Yup filename is 449001.xml .. works fine in Exscriptor which is what I've been using for some time - years in fact.

X-Studio has been pointed to Reunion folder - all seems OK - how do you set the mode ???

Looked in the help file, looked in every menu - where does it tell me what mode it is in (although it is clearly displaying the contents of 440001.xml because I loaded it and then compared it to the loaded game strings)

Even tried starting a project and adding my 449001.xml to it but it made no difference.

- I'm also guilty of being ultra dumb -- :oops: -- this question was aimed at the x-studio boys - got me freds muddled.

Whimsy
Posts: 167
Joined: Mon, 9. Feb 04, 21:32
x3tc

Post by Whimsy » Sat, 5. Oct 13, 11:13

TheHutt wrote:X-Studio has been pointed to Reunion folder - all seems OK - how do you set the mode ???
I thought you meant Exscriptor, but it sounds like you've already got that all working anyway. :) I don't think X-Studio has 'modes' - it just figures it out based on what game you've pointed it to.
TheHutt wrote:- I'm also guilty of being ultra dumb -- :oops: -- this question was aimed at the x-studio boys - got me freds muddled.
No worries! I tried it out with X-Studio as well and it seems like the custom language files do get loaded if they use the newer TC/AP style name: 9001-L044.xml. Try renaming your file like that and see if it works.

Post Reply

Return to “X³: Reunion - Scripts and Modding”