[XTM - GAMEPLAY] Gameplay discussion for Xtended Mod

The place to discuss scripting and game modifications for X³: Reunion.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

User avatar
DevilDog_016
Posts: 136
Joined: Thu, 8. Jan 09, 02:56
x3

Post by DevilDog_016 » Sun, 30. Jan 11, 05:50

This post will probably generate so many facepalms, the combined heat of face-palm friction will flash-ignite the atmosphere and kill us all...

After 2 months of parting ways with X3 (the fact that I couldn't transfer my X3 empire into XTM - and that the X3-X3 Converter does not seem to cooperate with me - completely bummed me out :( ) I couldn't stand it anymore.

So I started a new game to *ahem* test all the new features. And I can't get them going. The missile destroyer doesn't fire missiles, the frigate is equally unfunctional... even though I can get the "Heavy Missile Gun" weapon for them, they won't mount.

Also, Griffon won't make drones, and the OTAS shield frigate doesn't do anything... except being really big and attracting all the attention with the shiny golden Shield-Generators.


What am I doing wrong here? How do I get all the features on the ships? :?

Also, anyone knows a way to get the standard X3 savefiles over to XTM? As I said, the X3-X3 Converter mentions that it is possible, but for me it didn't seem to work. Any help here would be appreciated, as I really don't want to lose 400+ hours of work on my empire...
And if I do sacrifice it, the new one must be better, stronger, and have lots of ships firing missile cannons and launching 9001 drones and going PEWPEWPEWPEWssssskhBOOM! :D
Yo dawg, I heard you like plasma, so we put HEPTs in yo HEPTs so you can blast foos while you blast foos!

Proud owner of an original copy of Tachyon The Fringe.

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Sun, 30. Jan 11, 18:41

If nothing is working the way it should be, then perhaps you have a dodgy XTM installation?

If I remember rightly, there is an option in the Artificial Life menu, which will check your files and make sure they are installed correctly.

Try that.
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

User avatar
DevilDog_016
Posts: 136
Joined: Thu, 8. Jan 09, 02:56
x3

Post by DevilDog_016 » Tue, 1. Feb 11, 04:01

I don't see how it could be a dodgy XTM installation. It was done on a completely fresh installation of X3. I'm using a handful of scripts that I tested in-game so that they wouldn't mess with XTM. Here they are:


Anarkis Carrier Commands v1.41 (Anarkis Federation)
Asset Summary v1.01 (Carlo)
Autotrader Sector Lock v1.0 (halo)
Bounty Boost v1.0 (LV)
CMOD II for XTM 0.7.4 v1.10 (Ulfius)
Crew Chatter Ambient Plugin v1.0 (Ulfius)
Emergency Escape Transporter v1.00 (Cycrow)
LV's Cheats v1.4 (LV) - ironically, a plug-in that's supposed to make me NOT play the game proper made me realize I CAN'T play the game proper... I suppose this is why messing around with the game is sometimes good.
Military Hud MkII Plugin 2.0 (Ulfius)
OCS Apollo v1.0 (Laureati)
Player Friendly EQDocks v1.0 (Voxol)
Player Friendly Shipyards v2.0 (Voxol)
RRF Final v1.7a (LV)
Report Enemy Action v1.12 (eladan)
Sensor Boost Plugin v1.00 (Ulfius)
x0ne Turret Control System v1.02 (x0ne)
X3-X3 Converter v2.5 (SymTec ltd.)
XTM Speed Boods Plugin v1.10 (Ulfius)


Also, nothing under Artificial Life.
I get all the XTM ships, all the XTM wares, only not their appropriate functions. And I've gotten the error "File Not Found!!!" while playing several times now.

I can't see what's wrong here, and TBH I'm a bit tired of having to work around with such finicky things. I've already had one bad experience with a years-old TES4 Oblivion modded installation suddenly deciding to die on me... And right now I don't need to know that I've also sacrificed hundreds of hours in X3R for a mod that only half-works.


Allright. Let's give this a few more shots.

So I downloaded XTM 0.7.4 and installed it. That's all it came with - just an .exe that extracts all the files for XTM in a given folder. Nothing else.
Jumped in the game, new menuscreen, I get all the ships, the new weapons, all the goodies.
Problem is, all the new things don't work on any ships they should.
And I get some obscure, half-witted error that doesn't help with the problem.

So, am I doing something wrong? Missing files? What's going on here that's keeping my XTM installation from working?
Yo dawg, I heard you like plasma, so we put HEPTs in yo HEPTs so you can blast foos while you blast foos!

Proud owner of an original copy of Tachyon The Fringe.

Deeparth
Posts: 406
Joined: Fri, 30. Apr 10, 00:35
x3ap

Post by Deeparth » Tue, 1. Feb 11, 04:43

Just try reinstalling :D

User avatar
DevilDog_016
Posts: 136
Joined: Thu, 8. Jan 09, 02:56
x3

Post by DevilDog_016 » Tue, 1. Feb 11, 15:54

Deeparth wrote:Just try reinstalling :D
Again? Grrrh...Maybe I will do that.

Anyone got the latest links to the XTM downloads?
Also, it seems to me like 0.7.4 did NOT come with the scripts SPK package... For example, on the XTM page here, they have a file called "XtendedModScripts+Patch-0.7.3.SPK"

Supposedly, 0.7.4 includes the patch. What about the scripts file? In-game, I get the message that XTM has installed successfully, but then it's missing most of its functions.
Yo dawg, I heard you like plasma, so we put HEPTs in yo HEPTs so you can blast foos while you blast foos!

Proud owner of an original copy of Tachyon The Fringe.

User avatar
MBD
Posts: 338
Joined: Mon, 27. Mar 06, 17:03
x3tc

Post by MBD » Tue, 1. Feb 11, 18:25

The latest version of XTM is 0.7.5 and is available for download from here.
"We always were English and we always will be English and it's because we are English that we're sticking up for our rights to be Burgundians." - Passport to Pimlico 1949

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Tue, 1. Feb 11, 20:59

OK

1st of. There IS an entry in the Artificial Life menu. (I just checked it myself) 3rd option in the list. "Xtended. Check Mod Status" Or something like that. Set it to yes and you will see a message detailing the integrity of your XTM install.

I have version 0.7.5, so as long as you have the same version, you will be able to do the same.
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

User avatar
DevilDog_016
Posts: 136
Joined: Thu, 8. Jan 09, 02:56
x3

Post by DevilDog_016 » Wed, 2. Feb 11, 03:06

Yes, I found it. For some reason it didn't show up before. Now I get all the options. I run a check on XTM and it says it's all OK.

But still, I can't use the Heavy Missile Launcher - there's no way to actually equip it on the ship I'm piloting... I'll check the Griffon and the shield frigate later.

And I still get that obscure half-witted error. It happens randomly in-game, and also when trying to start a custom XTM game (i.e. Sentient Xenon, Split Militant, etc.)
Yo dawg, I heard you like plasma, so we put HEPTs in yo HEPTs so you can blast foos while you blast foos!

Proud owner of an original copy of Tachyon The Fringe.

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Wed, 2. Feb 11, 22:32

DevilDog_016 wrote:But still, I can't use the Heavy Missile Launcher - there's no way to actually equip it on the ship I'm piloting... I'll check the Griffon and the shield frigate later.
Check here. Paying special attention to the 2 lines typed in yellow. ;) That might help solve your Agamemnon problem.

As for the Griffon problem, have you got the necessary wares on board it, to build the drones?
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

zdan30
Posts: 198
Joined: Mon, 29. Jan 07, 15:20
x4

Post by zdan30 » Fri, 4. Feb 11, 12:17

I recently attempted a mission that i picked up in Seaweed drift from a split pilot in an m5 wanting me to follow an orca,he said that i had to keep within 10km,i did this and followed the orca for about 2-3 hours
The next part i think ill add to the spoilers just incase
Spoiler
Show


So i Reached the DarkWave research center after a long and painful trip through pirate ally,the split show up and i manage to defeat them and the station then blows up and im asked to open comms with a Pulo Du*

The problem is there is no ship in range with him on it, the mission effectively ended and i didnt receive any reward for its completion.
Im just curious what i was supposed to do to complete this mission and what i wouldve received.

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Sat, 5. Feb 11, 17:45

Strange that. I don't think I've seen that mission before. What version of XTM do you have?
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

zdan30
Posts: 198
Joined: Mon, 29. Jan 07, 15:20
x4

Post by zdan30 » Sat, 5. Feb 11, 19:41

Im not overly sure as i havent played this for a long time,on the main screen it says v2.5 but i have a feeling i downloaded 7.0c but i maybe mistaking that with another game.

It wouldve been the latest one i could find when i re-installed it about 6 months or so ago.

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Tue, 8. Feb 11, 21:31

Strange.....

Well, I believe the most up-to-date version is 0.75. Also have a look here. It lists all the XTM missions and their walkthroughs. I have not had the time to look thouroughly, but I cannot find the mission your talking about.
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

zdan30
Posts: 198
Joined: Mon, 29. Jan 07, 15:20
x4

Post by zdan30 » Wed, 9. Feb 11, 19:59

With the help of your link i found the mission http://www.thexuniverse.com/threads/57 ... SPOILERS!

It seems that i must have an older version and its bugged so i couldnt finish it no matter what i did,i needed the patch.

But thanks for the link its very handy as i can now see all the mission`s and what i would have to do should i except them.

Buck_Rogers
Posts: 1462
Joined: Tue, 21. Dec 04, 00:23
x3

Post by Buck_Rogers » Wed, 9. Feb 11, 20:38

zdan30 wrote:With the help of your link i found the mission
Ahem! :oops: Shows how much I know! :lol:
zdan30 wrote:But thanks for the link its very handy as i can now see all the mission`s and what i would have to do should i except them.


You are indeed most welcome. :wink:
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!

Post Reply

Return to “X³: Reunion - Scripts and Modding”