X3: Reunion (Steam) Comm Video Loop Glitch

Ask here if you experience technical problems with X³: Reunion, X²: The Threat, X-Tension or X-Beyond The Frontier

Moderators: timon37, Moderators for English X Forum

Post Reply
dawnrunner
Posts: 11
Joined: Fri, 9. Aug 19, 12:40

X3: Reunion (Steam) Comm Video Loop Glitch

Post by dawnrunner » Sun, 11. Aug 19, 15:58

Utilizing a fresh version downloaded from Steam on a Windows 10 machine, I've noticed that the communication video loops aren't aligning as they should - that is, another incorrect character briefly flashes-in at the beginning/end of each loop.

I've uninstalled and reinstalled twice with the same issue, and files validate just fine through Steam.

Is this a known issue with Reunion by any chance with a solution? I also have AB and TC through Steam, both installed, and comm videos for those seem to be looping appropriately without issue. :gruebel:

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 20081
Joined: Fri, 16. Apr 04, 19:21
x4

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by Alan Phipps » Sun, 11. Aug 19, 22:09

I found an old, old bug report for X3:R (Oct 2005) that might explain better what may be happening:

"= The picture displayed in a comms window when you receive a message will regularly default to the last person you talked to, before quickly flickering to the correct image."
A dog has a master; a cat has domestic staff.

dawnrunner
Posts: 11
Joined: Fri, 9. Aug 19, 12:40

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by dawnrunner » Sun, 11. Aug 19, 22:50

Thanks for thinking about it on my behalf! It's just the video that's off, and it's extra odd because it works just fine for Albion Prelude and Terran Conflict!

It also isn't the initial flash that you noted above. That is annoying, and I have experienced it as well, but this is something different See below for a link to a video I just took. The issue is with the looping portion at the end after the character is done speaking.

https://drive.google.com/file/d/1-3LaDb ... p=drivesdk

dawnrunner
Posts: 11
Joined: Fri, 9. Aug 19, 12:40

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by dawnrunner » Tue, 13. Aug 19, 15:36

No other thoughts on this front?

Tonight I may see if I can accurately time the amount of delay and try to manually offset it by nudging the video file forward a bit.

My biggest fear though, is that the issue only pertains to the "looped" portion - as if the values in the xml that defines them are off, and that if I move the entire video, it'll misalign the initial "speaking" section.

I suppose I could try and unpack things, find the xml file that defines the looped sections and adjust that, but frankly I'm not sure that I'm up to it at this point. I know that the video sections themselves are called out in the "videos" text file, but I don't recall the looping parameters being included, nor do I currently know where to find them. :(

If only adjusting the video didn't take a 15 minute export from my editor than another 15 minute conversion to MPEG1... trial and error would be much easier!

Any additional help would still be greatly appreciated!

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 20081
Joined: Fri, 16. Apr 04, 19:21
x4

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by Alan Phipps » Tue, 13. Aug 19, 20:47

No further thoughts here on that issue (I'm just another X game player and not even a modder :wink: ) but you might find this helpful in your further investigations even though it was related to later X3 games.
A dog has a master; a cat has domestic staff.

dawnrunner
Posts: 11
Joined: Fri, 9. Aug 19, 12:40

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by dawnrunner » Tue, 13. Aug 19, 21:36

Thanks :)

I’ve come across that thread while doing some research while working on my own pilot video mod.

I guess the good news is that I feel like I have a few good avenues for testing, so I’m not quite at the level of frustration where I don’t know what to do next.

I’m just more confused that it’s happening at all with a fresh install and no mods or adjustments! If anybody else has the latest Steam version of Reunion, would you mind checking and seeing if you experience the same thing? I wonder if this is maybe just what the latest Steam version does… and maybe everybody is too busy playing TC/AP to notice! :wink:

Video posted again for reference:
https://drive.google.com/file/d/1-3LaDb ... p=drivesdk

dawnrunner
Posts: 11
Joined: Fri, 9. Aug 19, 12:40

Re: X3: Reunion (Steam) Comm Video Loop Glitch

Post by dawnrunner » Wed, 14. Aug 19, 05:20

Update: seems like for whatever reasons the character/pilot animations are off by exactly 4 frames, but the wares and jobs section is fine as-is. Super weird. I've been able to nudge the character section only back by 4 frames and it seems to fix the issue.

Still curious if anybody else using a raw Steam download of Reunion experiences the same thing...

Post Reply

Return to “X³: Reunion, X²: The Threat, X-T and X-BTF - Technical Support”