[MOD] Guilds - BETA v0.22 - 2024/02/11

The place to discuss scripting and game modifications for X³: Farnham's Legacy

Moderators: Moderators for English X Forum, Scripting / Modding Moderators, Moderators for the X3:FL Forums

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 22188
Joined: Sun, 14. Nov 04, 23:26
x4

Re: [MOD] Guilds - BETA v0.21 - 2024/02/05

Post by Cycrow » Mon, 5. Feb 24, 20:11

Small update to fix a docking issue (unable to dock at most stations)

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.21 - 2024/02/05

Post by Tharrg » Sat, 10. Feb 24, 14:33

I am regular crash to desktop, getting more frequent and eventually leading to an unplayable save game.

User avatar
alexalsp
Posts: 1819
Joined: Fri, 18. Jul 14, 05:28
x4

Re: [MOD] Guilds - BETA v0.21 - 2024/02/05

Post by alexalsp » Sat, 10. Feb 24, 16:33

Tharrg wrote:
Sat, 10. Feb 24, 14:33
I am regular crash to desktop, getting more frequent and eventually leading to an unplayable save game.
With that much information, I don't think anyone can help you.

Describe the conditions under which this happens.
Provide the author with a save file
Have you installed any mods additionally

More data.

The author is not clairvoyant...

:x3: :roll:

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.21 - 2024/02/05

Post by Tharrg » Sun, 11. Feb 24, 00:46

alexalsp wrote:
Sat, 10. Feb 24, 16:33
Tharrg wrote:
Sat, 10. Feb 24, 14:33
I am regular crash to desktop, getting more frequent and eventually leading to an unplayable save game.
With that much information, I don't think anyone can help you.

Describe the conditions under which this happens.
Provide the author with a save file
Have you installed any mods additionally

More data.

The author is not clairvoyant...

:x3: :roll:
I will post a save game when I get my internet working.


To reproduce use Terran spy start and travel from sector to sector in starting ship. After 20 sectors get the first crash, after about 100 gamecant progress. Initially crash is about 4s after entering system for fist time but ends up about 4s after loading.


No mods other than guilds and unofficial patch. Played offline.

User avatar
alexalsp
Posts: 1819
Joined: Fri, 18. Jul 14, 05:28
x4

Re: [MOD] Guilds - BETA v0.21 - 2024/02/05

Post by alexalsp » Sun, 11. Feb 24, 02:10

Didn't fly through the sectors, but jumped. The game crashed, too. But I didn't see who the last sector belonged to, but I jumped on the sectors of splits.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 22188
Joined: Sun, 14. Nov 04, 23:26
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Cycrow » Sun, 11. Feb 24, 12:26

The issue with crashing was the Plasma Burst Generator. This is fixed in 0.22 (available now)

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Tharrg » Sun, 11. Feb 24, 16:54

Built Shamshir at hq. It had 7 electro magnetic emitters, but max installable is 2.

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Tharrg » Sun, 11. Feb 24, 21:55

Overmastet talon has a federal argonshipyard that should probably be a teladi shipyard.

KillroyS
Posts: 7
Joined: Mon, 22. Sep 14, 17:15
x3ap

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by KillroyS » Sun, 11. Feb 24, 22:16

This is on 0.21, but the Nemesis you get from the plot spawned with 9 Gamma Pulse Emitters (that is cannot equip). The demeter you find at the start of the plot also had gamma pulse emitters. Additionally, the pirates that spawn for you to kill in the plot had no weapons.

KillroyS
Posts: 7
Joined: Mon, 22. Sep 14, 17:15
x3ap

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by KillroyS » Mon, 12. Feb 24, 23:38

On 0.22, freighters / M6s (unsure if others) spawning with Gamma Pulse Emitters is still an issue. Some fighters still don't have any weapons either.

Also, is it possible to disable the revamped ore and silicon? I feel like I can't setup a beginner complex like i normally would because it's so expensive / there's no silicon wafers / metal alloys going around in space.

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Tharrg » Tue, 13. Feb 24, 11:48

I suspect the factions reputation system needs checking. For example are the entries in the encyclopedia correct - for example, auto-filled from faction settings or hand-crafted? I am not sure how this should work so difficult to pinpoint problems.

Eexample:
1) I do a Darkspace Taxi mission between two Darkspace sectors and only get Darkspace gain.
2) I immediately do a Darkspace Taxi mission between a Darkspace sector and Pluto. I get darkspace gain and Split and Paramd loss.

So those two appear inconsistent unless you need witnesses? Note this is Terran spy so Boron, Argon etc rep are bottomed out so probably don't secondary change.
Last edited by Tharrg on Tue, 13. Feb 24, 12:24, edited 1 time in total.

eldarmark
Posts: 120
Joined: Tue, 25. Dec 07, 06:47
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by eldarmark » Tue, 13. Feb 24, 11:49

On 0.22. The Pirate Armored Transport doesn't have the Armored Transport icon, it has the standard TS icon.

Tharrg
Posts: 257
Joined: Thu, 17. Feb 05, 16:09
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Tharrg » Wed, 14. Feb 24, 19:00

Dark space primising agent; should this be promising agent?

eldarmark
Posts: 120
Joined: Tue, 25. Dec 07, 06:47
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by eldarmark » Sat, 17. Feb 24, 13:32

I started up as Nostalgic Argon (so low notoriety, 0 combat/trade rank) and combat missions don't spawn enemies. Like a defend station mission will not spawn anything, and then after about 30-60 seconds the game congratulates me and gives me a reward.

Happens with defend freighter, patrol, defend station... I'm slowly getting my combat rank up but as of Greenhorn 0% I'm still not seeing anything spawn.

Edit: I figured it out. I just took a "defend this station" mission. Argon vs Split. Fight rank Rookie 0%.

Nothing spawned. So I went to the next sector, and a hostile Split M5 (my Split are set to Friend / "Foe-if-Foe") was just sitting there moving at 0/ms. He sat there until one of the locals attacked him, then he "woke up" and dogfought them forever until eventually dying.

So somehow mission ships are spawning too far from the gate instead of warping in immediately. Could it be that I set the Gate Safety to "Every Ship?" I'll turn that off and see if it helps.
Last edited by eldarmark on Sat, 17. Feb 24, 14:12, edited 1 time in total.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 22188
Joined: Sun, 14. Nov 04, 23:26
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Cycrow » Sat, 17. Feb 24, 14:01

Tharrg wrote:
Tue, 13. Feb 24, 11:48
I suspect the factions reputation system needs checking. For example are the entries in the encyclopedia correct - for example, auto-filled from faction settings or hand-crafted? I am not sure how this should work so difficult to pinpoint problems.

Eexample:
1) I do a Darkspace Taxi mission between two Darkspace sectors and only get Darkspace gain.
2) I immediately do a Darkspace Taxi mission between a Darkspace sector and Pluto. I get darkspace gain and Split and Paramd loss.

So those two appear inconsistent unless you need witnesses? Note this is Terran spy so Boron, Argon etc rep are bottomed out so probably don't secondary change.
These can depend alot on what your ranks are and what part of the plots you are. At certain part of the plots dynamic relations can be disabled for some races

Also, if you are quite low rank then gaining rank will also not trigger dynamic relations

The encyclopaedia entries should be correct, they are displayed based on the current notoriety levels between races

eldarmark
Posts: 120
Joined: Tue, 25. Dec 07, 06:47
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by eldarmark » Sat, 17. Feb 24, 21:21

So yeah, 3 things of note:

Hostile spawned ships seem to be spawning 1 sector over from their missions, but aren't using the gates. Previous behavior was they'd immediately warp in from the nearest gate and go for a beeline towards the target. I do not believe this is the new "gate protection" mechanic, I had that turned on for All Ships but turned it off and didn't see much change.

Ships appear to be spawning with weapons they cannot use in their hold and nothing equipped. This appears to mostly affect mission spawned ships, naturally spawning pirates, for example, are properly geared up. These ships all had Fighter Drone 2s and Banshee Missiles as well, for some reason.

Some ships related to the these two issues seem to have AI issues. A Nova with 6 of one of the new Xenon guns sat there at 0ms, only moving when I shot it, at which point it went at a leisurely 14ms rate away from me. A Split M5 that was in the wrong sector appears to have been doing the "explore sector" command over and over again.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 22188
Joined: Sun, 14. Nov 04, 23:26
x4

Re: [MOD] Guilds - BETA v0.22 - 2024/02/11

Post by Cycrow » Mon, 19. Feb 24, 19:09

eldarmark wrote:
Sat, 17. Feb 24, 21:21
So yeah, 3 things of note:

Hostile spawned ships seem to be spawning 1 sector over from their missions, but aren't using the gates. Previous behavior was they'd immediately warp in from the nearest gate and go for a beeline towards the target. I do not believe this is the new "gate protection" mechanic, I had that turned on for All Ships but turned it off and didn't see much change.

Ships appear to be spawning with weapons they cannot use in their hold and nothing equipped. This appears to mostly affect mission spawned ships, naturally spawning pirates, for example, are properly geared up. These ships all had Fighter Drone 2s and Banshee Missiles as well, for some reason.

Some ships related to the these two issues seem to have AI issues. A Nova with 6 of one of the new Xenon guns sat there at 0ms, only moving when I shot it, at which point it went at a leisurely 14ms rate away from me. A Split M5 that was in the wrong sector appears to have been doing the "explore sector" command over and over again.
Its fairly normal for ships to spawn in the next sector, they are usually spawned behind the gate, then fly through, rather than spawning directly at the game. So is so the ships appear the same as any ship flying through the gate, rather than just randomly appearing close to the gate.

i believe the issue is probably related to the weapons. If i ship doesn't have suitable weapons, then some of the combat scripts wont function. So its likely they are not doing anything because they have to weapons to start any of the combat commands.

The weapons should be fixed in 0.3 (Will require Unofficial Patch 1.3.14)

Post Reply

Return to “X³: Farnham's Legacy - Scripts and Modding”