[6.0 Beta 1] Average FPS reduces badly over time.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

User avatar
alt3rn1ty
Posts: 1601
Joined: Thu, 26. Jan 06, 19:45
x4

[6.0 Beta 1] Average FPS reduces badly over time.

Post by alt3rn1ty » Sat, 21. Jan 23, 12:09

I noticed that over a 12 hour period FPS in the game declines.

As a test I went to a less busy sector, Savage spur, and sat my ship Kuraokami on my solar power plant there.

Usually I get circa 60fps on this station (unless I open the map .. but thats a different story)

After landing at this station, I left the game running again overnight. Using the games own FPS counter to monitor, when I went to sleep the FPS was at 60.
After 12 hours running the game went down to 19 FPS. There was no increased activity in the sector.

Save game - Landed at the station - https://www.dropbox.com/s/ozqnmey5i18qy ... ml.gz?dl=0

Load this up, get the FPS counter on screen and note the initial FPS .. Then leave alone it for 12 hours.

DXDiag + Vulkaninfo - https://www.dropbox.com/s/da6rmtfis1ll5 ... 23.7z?dl=0

System specs are in my signature. All drivers are current. No additional apps are running. No third party mods in use (ever).

Config.xml :

Code: Select all


<?xml version="1.0" encoding="UTF-8"?>
<root>
  <!-- graphic options -->
  <fullscreen>false</fullscreen>
  <borderless>true</borderless>
  <antialiasing>fxaa_low</antialiasing>
  <upmode>fsr_quality</upmode>
  <presentmode>mailbox</presentmode>
  <colorcorrection>0</colorcorrection>
  <gamma>1.00</gamma>
  <capturehq>false</capturehq>
  <gfxquality>0</gfxquality>
  <!-- high gfx preset -->
  <shaderquality>2</shaderquality>
  <shadows>2</shadows>
  <softshadows>true</softshadows>
  <ssao>2</ssao>
  <glow>2</glow>
  <lodfactor>0.60</lodfactor>
  <effectdistance>0.60</effectdistance>
  <distortion>true</distortion>
  <disableradar>false</disableradar>
  <radarquality>1</radarquality>
  <ssr>true</ssr>
  <ssrquality>low</ssrquality>
  <texturequality>high</texturequality>
  <chromaticaberration>true</chromaticaberration>
  <volumetric>1</volumetric>
  <!-- sound options -->
  <nosound>false</nosound>
  <volumetotal>1.00</volumetotal>
  <volumemusic>0.80</volumemusic>
  <volumevoice>1.00</volumevoice>
  <volumeambient>1.00</volumeambient>
  <volumeui>1.00</volumeui>
  <volumeeffects>1.00</volumeeffects>
  <!-- game options -->
  <subtitles>true</subtitles>
  <autosave>false</autosave>
  <autoroll>false</autoroll>
  <toggleboost2>false</toggleboost2>
  <togglemouselook>false</togglemouselook>
  <rumbleintensity>1.00</rumbleintensity>
  <aimassist>1</aimassist>
  <collisionassist>true</collisionassist>
  <controlmodemessages>true</controlmodemessages>
  <radarmode>false</radarmode>
  <stopshipinmenu>false</stopshipinmenu>
  <forceshootatcursor>false</forceshootatcursor>
  <fpusecameraforward>false</fpusecameraforward>
  <separateRadar>true</separateRadar>
  <speaktargetname>true</speaktargetname>
  <autosaveintervalfactor>1.00</autosaveintervalfactor>
  <emergencyeject>true</emergencyeject>
  <mouseovertext>true</mouseovertext>
  <cockpitcamerascale>1.00</cockpitcamerascale>
  <!-- input options -->
  <confinemouse>false</confinemouse>
  <gamepadmode>2</gamepadmode>
  <tobiimode>combined</tobiimode>
  <tobiianglefactor>1.00</tobiianglefactor>
  <tobiigazeanglefactor>0.40</tobiigazeanglefactor>
  <tobiipositionfactor>1.00</tobiipositionfactor>
  <tobiideadzoneangle>0.00</tobiideadzoneangle>
  <tobiideadzoneposition>0.00</tobiideadzoneposition>
  <tobiigazedeadzone>0.10</tobiigazedeadzone>
  <tobiifilterstrength>5</tobiifilterstrength>
  <tobiigazefilterstrength>30</tobiigazefilterstrength>
  <!-- online options -->
  <showvisitornames>false</showvisitornames>
  <highlightvisitors>true</highlightvisitors>
  <!-- privacy options -->
  <sendcrashreports>true</sendcrashreports>
  <!-- accessibility options -->
  <showsignalleakviz>true</showsignalleakviz>
  <showlongrangescanviz>true</showlongrangescanviz>
  <!-- modified settings -->
  <chardensity>0.50</chardensity>
  <trafficdensity>0.20</trafficdensity>
  <res_width>1360</res_width>
  <res_height>768</res_height>
  <compress>true</compress>
  <enemywarning_nearby>ui_notification_player_alert_12</enemywarning_nearby>
  <uiscale>1.1</uiscale>
  <pom>medium</pom>
  <envmapprobes>high</envmapprobes>
</root>

I have been playing around with all the new graphics settings in the last couple of days, the game engine sets things a touch too high imho, so I have tweaked a few settings down, and allowed myself to have a few more bells & whistles on than I usually have.

GPU usage is around 41%
CPU usage is around 4-7% (used Windows 11 Game bar to occasionally monitor these), and is not going into boost mode up to 5ghz I think the CPU cores are mostly staying down at 2.2ghz
Machine is running quite cool (the laptop fans are not going into loud overdrive mode anyway, and the case is cool to touch).

Prior to 6.0 Beta 1, I did not experience the same issue.
Laptop Dell G15 5510 : Win 11 x64
CPU - 10th Gen' Core I7 10870H 2.2-5.0ghz, GPU - NVidia Geforce RTX 3060, VRAM 6gb GDDR5,
RAM - 32gb (2x16gb Dual Channel) DDR4 2933mhz Kingston Fury Impact,
SSD - Kioxia M.2 NVME 512gb (System), + Samsung M.2 NVME 970 Evo Plus 1tb (Games)

:boron: Seeker of Sohnen.

User avatar
alt3rn1ty
Posts: 1601
Joined: Thu, 26. Jan 06, 19:45
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by alt3rn1ty » Sat, 21. Jan 23, 12:21

Forgot to include screenshots of the game with in-game FPS counter :

This screenshot show the typical FPS after loading the game for a few minutes ..
https://i.imgur.com/ZXBLTQP.png

This is a screenshot showing the FPS after leaving the game alone for 12 hours ..
https://i.imgur.com/1jz62QH.png
Laptop Dell G15 5510 : Win 11 x64
CPU - 10th Gen' Core I7 10870H 2.2-5.0ghz, GPU - NVidia Geforce RTX 3060, VRAM 6gb GDDR5,
RAM - 32gb (2x16gb Dual Channel) DDR4 2933mhz Kingston Fury Impact,
SSD - Kioxia M.2 NVME 512gb (System), + Samsung M.2 NVME 970 Evo Plus 1tb (Games)

:boron: Seeker of Sohnen.

Scoob
Posts: 8854
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Scoob » Sat, 21. Jan 23, 14:51

I experienced something similar myself last night, if it's ok, I'll share my experience here...

I've been hanging out in Second Contact II - Flashpoint. This has been a busy sector for me, and by far the least performant - I assume precisely because it's so busy. Sector has generally quite high traffic levels, but also regular incursions by HOP and the odd Xenon Capital ship causing havoc. I considered this sector a good place to check for any performance improvements due to it being busy. With relatively minor incursions - a couple of Destroyers and a load of Fighters deployed on both sides - performance was as bad as it's gotten in this fresh game. FPS in the low-30's was "normal" when any sort of invasion was going on - which was when I first turned up.

However, what surprised me was, after the invasion had been defeated, performance did not get any better. So, I'm in a still busy Second Contact II - Flashpoint, but there's no active HOP incursion, just regular traffic, yet my fps was still in the 30's. Pretty bad. Another small invasion began and I stuck around for a while, performance remaining in the 30's. I'm used to battles resulting in a performance drop but, equally, I'd expect things to recover once the battle ends. It did not.

Now, I saved for the night at this point, only loading up the game again today. There are a few HOP ships still in sector - I'd estimate about 20 Fighters (that I can see) and one invading destroyer - however, I'm getting a solid 60fps now in the exact same situation.

Basically, I played in a "busy" sector that had a fairly substantial HOP incursion active and had around 30 fps - not great. That invasion was defeated and fps remained around 30. A new (somewhat lesser) incursion by HOP forces occurred and performance was still at around 30. I was wondering why this sector seemed to consistently perform badly, seemingly irrespective of what was going on. I save for the night and, reloading just now, performance is GREAT a solid (limited in Profile) 60fps. Yet the same second incursion is still on-going.

I've observed before, in the current 5.10 HF3 game most recently, that often-times a save / reload cycle will restore some fps in certain situations. This is quite an extreme example though. I have the save of course, but when I load it, performance is great, so it doesn't show what I was experiencing last night.

I hope it's ok to add this here, to this similar report.

User avatar
alt3rn1ty
Posts: 1601
Joined: Thu, 26. Jan 06, 19:45
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by alt3rn1ty » Sat, 21. Jan 23, 14:59

Yep concur with this symptom.

I can fly away from the sector once the FPS has been reduced after the 12 hours, and the FPS does not dynamically recover as it used to pre-6.0 beta 1.
I dare not open the map after the FPS has gone down, I did try it and went down to single figure FPS.
Laptop Dell G15 5510 : Win 11 x64
CPU - 10th Gen' Core I7 10870H 2.2-5.0ghz, GPU - NVidia Geforce RTX 3060, VRAM 6gb GDDR5,
RAM - 32gb (2x16gb Dual Channel) DDR4 2933mhz Kingston Fury Impact,
SSD - Kioxia M.2 NVME 512gb (System), + Samsung M.2 NVME 970 Evo Plus 1tb (Games)

:boron: Seeker of Sohnen.

Scoob
Posts: 8854
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Scoob » Sat, 21. Jan 23, 15:11

That's actually a key point there. In the current version v5.10 HF3, often the act of just leaving a sector and returning (very easy with teleportation tech) was enough to recover performance. I.e. a big scrap was going on In Sector, you teleport away to let it resolve its self, then return to nice fps again. Last night, while I was mostly hanging out in Second Contact II - Flashpoint, I did take the odd trip (in a ship, no teleportation tech yet) elsewhere. However, each time I returned to that sector - irrespective of what was going on - performance wasn't good. After a simple Save (last night) and Reload (this afternoon) though, and the Sector is performing really well. Note: Performance was better away from that sector, but not great.

I will add, that my gaming session was only a couple of hours or so between reloads, my game wasn't running for 12 hours like in your example. Despite that, I too suffered quite poor performance degradation I'm actually shocked at how much performance has been recovered by that Save / Reload. Game is playing as I type this (different PC) and I'm still at a solid 60fps (limited).

My own observations haven't been particularly scientific, but wanted to share the whole "longer session = performance degradation" thing. For me, the performance appears to degrade quicker the busier the sector is. So, while not great is makes sense as there's (for example) a big fight going on, so degradation is expected. However, saving then reloading into that same situation, performance is GREAT again, so why did it get so bad in the first place? What was going on in the game that was NOT preserved in that Save? How can we demonstrate this?

adeine
Posts: 787
Joined: Thu, 31. Aug 17, 17:34
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by adeine » Sat, 21. Jan 23, 15:14

Have you looked at memory consumption (both ram and vram)?

Could be there's a leak.

Scoob
Posts: 8854
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Scoob » Sat, 21. Jan 23, 15:45

adeine wrote:
Sat, 21. Jan 23, 15:14
Have you looked at memory consumption (both ram and vram)?

Could be there's a leak.
I did, no issues with either. RAM sorta varies from 8 to 12GB (32GB installed), VRAM peeks at around 6.5GB after playing for a bit (8GB card).

Quirkz
Posts: 13
Joined: Sun, 24. May 20, 18:35
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Quirkz » Sun, 22. Jan 23, 00:44

What happened when you quit the game and restarted? Did performance recover, or was it permanently bad?

Imperial Good
Moderator (English)
Moderator (English)
Posts: 4349
Joined: Fri, 21. Dec 18, 18:23
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Imperial Good » Sun, 22. Jan 23, 10:09

It is generally expected that after a new game start performance will decrease to some extent as the NPC factions expand causing the overall universe to become more complex. However such large reduction should not happen.

If saving and then restarting X4 restores performance back to approximately previous levels that generally points towards some kind of resource or complexity leak.

Scoob
Posts: 8854
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Scoob » Sun, 22. Jan 23, 20:43

I'm of course not speaking for the OP here, however, in my case, where I've been getting the worst apparent performance drop over time was totally resolved by a save / reload cycle.

Despite hanging out in the same area, I've not experienced the same performance drop as before. I cannot identify which "event" - even if it was just one - suddenly caused performance to degrade. I assumed it was just the game still being pretty bad when there's combat going on near the player. However, a simple Save / Reload at a moment of poor performance totally resolved things.

As mentioned, something certainly goes a bit wrong over time, with CPU / GPU resource usage dropping alongside the frame rate. Whatever it is causing this is, thankfully for the player, not preserved in a saved game. I still don't know how we can demonstrate this issue when it occurs when the save does not preserve the experience the player had at the moment that save was taken.

This type of slowdown, where PC resource usage drops is by no means new. However, certainly in my example, it was quite extreme.

User avatar
alt3rn1ty
Posts: 1601
Joined: Thu, 26. Jan 06, 19:45
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by alt3rn1ty » Sun, 22. Jan 23, 23:01

Scoob wrote:
Sat, 21. Jan 23, 15:45
adeine wrote:
Sat, 21. Jan 23, 15:14
Have you looked at memory consumption (both ram and vram)?

Could be there's a leak.
I did, no issues with either. RAM sorta varies from 8 to 12GB (32GB installed), VRAM peeks at around 6.5GB after playing for a bit (8GB card).
Just did a 24 hour test in this :

Used Win 11 Game Bar to monitor VRAM and RAM use.

Started with the save in the OP, 60 FPS per normal (I have the game capped at 60)
Readings

VRAM at start = 39% 2.3 of 6gb
RAM ar start = 43% 13.8 of 31.8gb

VRAM plus 24hrs = 53% 3.2 of 6gb
RAM plus 24hrs = 87% 27.8 of 31.8gb

FPS has gone down drastically again as per the OP to 20-22fps.

VRAM not so worried, I mean its in a sector which has the Yaki base, and my Solar Power Plant (just a low module thing my ship is landed on). The Xenon havent set foot in here for years now, I have a couple of Rattlesnake on patrol, and apart from that there will probably have been a few traders over the last 24 hours increasing the amount of cached textures etcetera steadily.

RAM on the otherhand, wow thats quite a lot being taken up by this game over one day.
Laptop Dell G15 5510 : Win 11 x64
CPU - 10th Gen' Core I7 10870H 2.2-5.0ghz, GPU - NVidia Geforce RTX 3060, VRAM 6gb GDDR5,
RAM - 32gb (2x16gb Dual Channel) DDR4 2933mhz Kingston Fury Impact,
SSD - Kioxia M.2 NVME 512gb (System), + Samsung M.2 NVME 970 Evo Plus 1tb (Games)

:boron: Seeker of Sohnen.

Scoob
Posts: 8854
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Scoob » Sun, 22. Jan 23, 23:30

To a degree, when you have a lot of RAM games and applications will hold on to it longer. I mean, you have plenty, why free it up, it might be needed again soon. You see this a lot where people quite adamantly state things like "Game X NEEEDZZZZ 16GB RAM cos on MY system it's using 15GB".

I often see quite high RAM usage. Currently, I've been playing a couple of hours, X4.exe is reporting a 11.5GB Working Set (actively in use) with 18GB overall Private Bytes (the total with stuff that's cached, perhaps using the swap file, depending on how much RAM you have) *

* This is a very simplified description.

I will say that v6.0 appears to be using MORE RAM than the v5.10 HF3. I have 32GB, so I consider this GOOD. Keep it in RAM, there's plenty!

ManuelEgosoft
EGOSOFT
EGOSOFT
Posts: 6
Joined: Tue, 4. Jan 22, 10:57

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by ManuelEgosoft » Tue, 24. Jan 23, 11:32

I tried to reproduce your issue with our current codebase. But even overnight, I could not observe anything wrong. Therefore, I would like to ask you to test it yourself again, when we release our next beta.

iNelsy
Posts: 28
Joined: Sat, 30. Apr 16, 11:27
x4

[Feedback][6.0 Beta 1] After short game like half hour, FPS drops

Post by iNelsy » Tue, 24. Jan 23, 16:36

The issue cause ultra graphics with 4k resolution and low graphics 1080p almost had no FPS difference, see example on the video
https://youtu.be/IS2sTW4FG64
System configuration
Show
GPU: MSI GeForce RTX 4090 SUPRIM LIQUID X [RTX 4090 SUPRIM LIQUID X 24G]
CPU: Intel(R) Core(TM) i9-13900K BX8071513900K
CPU Cooling system: ASUS ROG STRIX LC II 360 ARGB Black 360mm 90RC00F1-M0UAY0 (barely handle the CPU ><)
Memory: KINGSTON FURY Renegade RGB 32GB (16GB x2) DDR5-6400 (KF564C32RSAK2-32)
Motherboard: ASUS ROG STRIX Z790-E GAMING WIFI (LGA1700, ATX)
Operating system: Windows 11 x64 version 22H2 OS build 22621.1105

iNelsy
Posts: 28
Joined: Sat, 30. Apr 16, 11:27
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by iNelsy » Tue, 24. Jan 23, 19:15

Just in case here is the save file where I had fps issues. The save file is just full clean new company start in the beta client [6.00 Beta 492332] I'm not sure what company it was, but I have only one mission in the save file and this is the company mission, so while I was doing this mission steps up to the moment where I saved I assume my fps slowly getting worse, and after battle at the station where i saved, it become even worse. You can see on the video one post above I had around 70 fps at the end of the settings manipulations, but after game reload the fps grow alot.
https://1drv.ms/u/s!AnLQT6Hy1sS4g8A7ith ... A?e=JbXxIE
System configuration
Show
GPU: MSI GeForce RTX 4090 SUPRIM LIQUID X [RTX 4090 SUPRIM LIQUID X 24G]
CPU: Intel(R) Core(TM) i9-13900K BX8071513900K
CPU Cooling system: ASUS ROG STRIX LC II 360 ARGB Black 360mm 90RC00F1-M0UAY0 (barely handle the CPU ><)
Memory: KINGSTON FURY Renegade RGB 32GB (16GB x2) DDR5-6400 (KF564C32RSAK2-32)
Motherboard: ASUS ROG STRIX Z790-E GAMING WIFI (LGA1700, ATX)
Operating system: Windows 11 x64 version 22H2 OS build 22621.1105

iNelsy
Posts: 28
Joined: Sat, 30. Apr 16, 11:27
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by iNelsy » Wed, 25. Jan 23, 00:01

System configuration
Show
GPU: MSI GeForce RTX 4090 SUPRIM LIQUID X [RTX 4090 SUPRIM LIQUID X 24G]
CPU: Intel(R) Core(TM) i9-13900K BX8071513900K
CPU Cooling system: ASUS ROG STRIX LC II 360 ARGB Black 360mm 90RC00F1-M0UAY0 (barely handle the CPU ><)
Memory: KINGSTON FURY Renegade RGB 32GB (16GB x2) DDR5-6400 (KF564C32RSAK2-32)
Motherboard: ASUS ROG STRIX Z790-E GAMING WIFI (LGA1700, ATX)
Operating system: Windows 11 x64 version 22H2 OS build 22621.1105

iNelsy
Posts: 28
Joined: Sat, 30. Apr 16, 11:27
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by iNelsy » Wed, 25. Jan 23, 00:28

btw, in non beta version I played in last month, I had no such FPS problems I feel it matter to mention the FPS was stable for long play session. If I load this save file now the fps will be 85-105 depends on direction you look and its with ultra settings, 2k resolution with SSAAx4 (no FSR). The chronology was like this, I had storyline mission fight at the station and at the point I start feeling hard FPS worseining, then right after this fight I saved game (which available by save file presented above in one of my messages), I tried to make sense what happening then after some time to this station arived this piece of art I captured on video how it getting destroyed by station. If you load save file, maybe it could be reproduced if it would be possible to repead this stage of the mission, there is only one mission in the list and its storyline mission with many stages.
System configuration
Show
GPU: MSI GeForce RTX 4090 SUPRIM LIQUID X [RTX 4090 SUPRIM LIQUID X 24G]
CPU: Intel(R) Core(TM) i9-13900K BX8071513900K
CPU Cooling system: ASUS ROG STRIX LC II 360 ARGB Black 360mm 90RC00F1-M0UAY0 (barely handle the CPU ><)
Memory: KINGSTON FURY Renegade RGB 32GB (16GB x2) DDR5-6400 (KF564C32RSAK2-32)
Motherboard: ASUS ROG STRIX Z790-E GAMING WIFI (LGA1700, ATX)
Operating system: Windows 11 x64 version 22H2 OS build 22621.1105

User avatar
alt3rn1ty
Posts: 1601
Joined: Thu, 26. Jan 06, 19:45
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by alt3rn1ty » Wed, 25. Jan 23, 01:50

ManuelEgosoft wrote:
Tue, 24. Jan 23, 11:32
I tried to reproduce your issue with our current codebase. But even overnight, I could not observe anything wrong. Therefore, I would like to ask you to test it yourself again, when we release our next beta.
Will do :thumb_up:
Laptop Dell G15 5510 : Win 11 x64
CPU - 10th Gen' Core I7 10870H 2.2-5.0ghz, GPU - NVidia Geforce RTX 3060, VRAM 6gb GDDR5,
RAM - 32gb (2x16gb Dual Channel) DDR4 2933mhz Kingston Fury Impact,
SSD - Kioxia M.2 NVME 512gb (System), + Samsung M.2 NVME 970 Evo Plus 1tb (Games)

:boron: Seeker of Sohnen.

Szines Geza
Posts: 142
Joined: Thu, 29. May 14, 19:53
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by Szines Geza » Wed, 25. Jan 23, 07:01

I once posted something very similar, but I can't find the post.
https://youtu.be/z3vbb7KacWI This is the speed of a game that has been running for 34 hours. :)
I uploaded it a year ago. It's not so much the speed that's interesting, but the unbearable lags! Must be a synchronisation problem.

CBJ
EGOSOFT
EGOSOFT
Posts: 49739
Joined: Tue, 29. Apr 03, 00:56
x4

Re: [6.0 Beta 1] Average FPS reduces badly over time.

Post by CBJ » Wed, 25. Jan 23, 09:22

If it's a year ago, then it has nothing to do with 6.00 and doesn't belong in this forum. Please see the forum rules and stay on topic.

Post Reply

Return to “X4: Foundations - Public Beta Feedback”