[3.30 beta 1] Wares lost after station hack despawn too quickly

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Scoob
Posts: 7480
Joined: Thu, 27. Feb 03, 23:28
x4

[3.30 beta 1] Wares lost after station hack despawn too quickly

Post by Scoob » Tue, 30. Jun 20, 03:21

Hi,

No save, it was too late, so I'll describe what happened.

I got a notification of a Hack at one of my stations. I instantly paused the game and checked it out. Sure enough an SCA Plunderer Phoenix Vanguard was right next to my station and my wares, tens of thousands of them, were strewn around the area. I ordered my Destroyer Group - who were right next to the station - to take out the Phoenix. Meanwhile I ordered another ship to collect all wares in area. I then hit the Pause key again to resume the game.

The problem is that ALL my wares despawned at once, about five seconds later. I've lost literal millions of credits in the space of ten seconds.

Note: the wares are definitely lost, as I can see the storage graph tanking for each ware when I examine it.

Prior to v3.30 I've successfully collected most of the dropped wares - I generally keep a couple of M-Class Transporters around just for this reason. However, the wares despawn MASSIVELY too soon now.

In summary:

1) Alerted to station Hack - game paused instantly
2) Ordered attack on Pirate Destroyer
3) Ordered ships to collect my Wares
4) Resumed Game.
5) Five Seconds later ALL my dropped wares vanish.

Ware loss verified in Storage Levels statistics.

Really, a Station with Cargo Drones should retrieve any lost wares automatically, not that this would have helped in this case.

Scoob.

Mysterial
Posts: 508
Joined: Wed, 6. Nov 02, 21:31
x4

Re: [3.30 beta 1] Wares lost after station hack despawn too quickly

Post by Mysterial » Tue, 30. Jun 20, 04:13

I don't see any indication that a hacked notification was added in this beta, either in the changelog or in obvious candidate locations in the script code. Are you sure that's a vanilla notification?

Scoob
Posts: 7480
Joined: Thu, 27. Feb 03, 23:28
x4

Re: [3.30 beta 1] Wares lost after station hack despawn too quickly

Post by Scoob » Tue, 30. Jun 20, 12:22

Mysterial wrote:
Tue, 30. Jun 20, 04:13
I don't see any indication that a hacked notification was added in this beta, either in the changelog or in obvious candidate locations in the script code. Are you sure that's a vanilla notification?
Hmm, I thought it was a vanilla addition, but perhaps not. I know in this instance my standard Alerts did not trigger, but they're delayed sometimes. Regardless, all dropped wares vanished in seconds after being ejected from the station.

Note: I do use a handful of mods, apologies, I thought I'd mentioned it in my post but I see now I did not. I just continued my v3.2 game in v3.3 Beta and noticed that dropped wares from my station despawned very quickly now.

Scoob.

Post Reply

Return to “X4: Foundations - Public Beta Feedback”