Page 3 of 3

Re: [WIP] Custom Ship mod - Help needed!

Posted: Fri, 1. Mar 19, 19:44
by BrummBear02
you should really join discord ^^

you need to clean up your model.

press tab to go edit mode, press A to select everything, left bottom press mesh, press clean up, press delete loose.
then enter UV editing if u made changes to UV maps, klick in 3d view part and select all. (pressing A again) then select the UV map and unlink it again. now export.

Image
Image

also u can stay at 2.8 if its that bad for you to switch down to 2.7x but then ull have to play around till u find the correct export options ^^

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 07:04
by Cadius
Thanks Brumm, I got the model ingame now but i think I messed up something since the ship looks rusty AF.
https://i.imgur.com/LYeLXeV.jpg


{Images posted directly to the forums should not be greater than 640x480 or 100kb, oversize image now linked - Terre}

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 07:46
by Matterom
Cadius wrote:
Sat, 2. Mar 19, 07:04
Thanks Brumm, I got the model ingame now but i think I messed up something since the ship looks rusty AF.
Do you have one rendered outside the build menu? maybe with a skin?? The build menu can have odd texture artifacting, though.. never usually with a default skin.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 07:53
by Cadius
I messed up the vertex coloring, fixed it now and it appears correctly in the build menu. Now coding issues i think, I got the ship in the build menu but when i build it the shipyard doesn't complete the construction. The timer jumps straight to 0.00 and sits there. The shipyard isn't lacking resources since it says Everything is OK in the build menu.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 16:27
by BrummBear02
its been a while since i ran into that issze. its defenitly something in the ship XML or macro file. sadly i cant tell u the exact cause, id need to take a look on the files.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 16:52
by mr.WHO
I wonder how much work is needed for mod made ship to work with ingame "paint mods"?
I mean there is 50+ paints, so you need to made them all work one by one or there is some kind of template, so that you just need to texture ship once and it will work with all paint mods?

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 17:01
by KrYcHokE
All paint mods just tailed on the areas marked by red mask in second vertex color channel.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sat, 2. Mar 19, 17:38
by BrummBear02
mr.WHO wrote:
Sat, 2. Mar 19, 16:52
I wonder how much work is needed for mod made ship to work with ingame "paint mods"?
I mean there is 50+ paints, so you need to made them all work one by one or there is some kind of template, so that you just need to texture ship once and it will work with all paint mods?
viewtopic.php?p=4849134#p4849134

Re: [WIP] Custom Ship mod - Help needed!

Posted: Mon, 4. Mar 19, 18:54
by Cadius
Progress! I got the ship ingame - basically rebuilt the xmls using BrummBear's Split Raptor.
https://i.imgur.com/vt1VyUS.jpg
https://i.imgur.com/yuO1EBG.jpg
There's a bit of an issue with the ship though, all the mesh that I mirrored in blender seem to have inverted textures but look completely fine in the build menu.



{Images posted directly to the forums should not be greater than 640x480 or 100kb, oversize image now linked - Terre}

Re: [WIP] Custom Ship mod - Help needed!

Posted: Mon, 4. Mar 19, 20:36
by BrummBear02
oh, i remember the raptor xml beeing a mess with commented out stuff and leftovers from learning

when u mirror meshes in edit mode the normals get flipped. u now have to flip normals by hand or use the bisect tool to cut your model in half and mirror it again using the mirror modifier, which doesnt flip normals.

press N, scroll down and activate backface culling. that way faces u look at from the wrong side will get see through. not suited for actual modeling but great for checking normals.

if u select a face in edit mode u can go mesh -> normals - flip normals. also works if u select multible faces.

the bisect way: go edit mode, select all by pressing A, on the left go tools, Bisect. Draw a line somewhere. press F6. plane normal X is 1, rest is 0. check clear inner or outer box. not both. done, ur mesh is cut in half in the middle along the Y axis.
now go object mode, select your mesh in the outliner, go modiiyers (the blue wrench) add modifier, generate - mirror. if ur origin isnt centered this might behave funny so generade a duplicate of ur mesh first and merge it after u confirmed the mirror worked the way u want.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Sun, 10. Mar 19, 19:19
by Cadius
Alright, thanks for the help everyone. If I have more questions I'll post them in BrummBear's tutorial thread. Might be better to have everything in one place.

Re: [WIP] Custom Ship mod - Help needed!

Posted: Tue, 24. Dec 19, 01:10
by Shuulo
Cadius wrote:
Sun, 10. Mar 19, 19:19
Alright, thanks for the help everyone. If I have more questions I'll post them in BrummBear's tutorial thread. Might be better to have everything in one place.
Any update for that ship?

Re: [WIP] Custom Ship mod - Help needed!

Posted: Fri, 29. May 20, 14:00
by Max Bain
Still waiting for this ship. :D
How can someone go so far and then not finish it :? :(