[MOD] X4 Sound Overhaul v1.30

The place to discuss scripting and game modifications for X4: Foundations.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

[MOD] X4 Sound Overhaul v1.30

Post by Neloth23 » Thu, 13. Feb 20, 20:35

X4 Sound Overhaul v1.30 for X4 Foundations 3.0 (beta)

Download link: https://www.nexusmods.com/x4foundations ... escription

1. Description

The purpose of this mod is to enhance the sounds of X4 Foundations and give them a more cinematic aspect than in vanilla.

Changed sounds include :
  • Weapons
  • Reactors
  • Interface
  • Explosions
  • Impacts
  • And more...
The balance of the sounds has also been reworked from vanilla, to get better dynamics. Sounds should be more natural and less aggressive while still loud enough when needed.

The sound effects used in this mod come from a variety of sources, such as other games (Batman Arkham Knight, Elite Dangerous, Starpoint Gemini, Homeworld), royalty free sounds as well as a few custom sounds I created specifically for this mod.

Check this video to get an idea of the changes:

https://youtu.be/6-p71hYqFYQ


2. What this mod will NOT be

This mod does not intend to be a full replacement of all the in-game sounds. I might modify additional sounds in the future if I find satisfying alternatives or new ideas, but no promises.

3. Mono vs. Stereo

For this mod, I chose to use stereo sounds for some effects to get the best quality. However, in doing so, sounds are not as well spatialised. Furthermore, some users reported a few glitches, as the engine doesn't always handle stereo very well. I had no issue on my end during testing, so I think it may vary depending on the configuration and I unfortunately can't fix it.

For that reason, there is now a 100% mono version of the mod, so you no longer have to stick with stereo if it is not your cup of tea or if you experience glitches. It offers good spatialisation and a possible smoother experience than stereo.

I still recommend the stereo version as it is IMHO the best sounding of the two , but now you're free to get whichever version you prefer!

4. Compatibility

X4 Sound Overhaul is save game compatible.

This mod should be compatible with other mods, except of course anything changing the sound effects.

It should be compatible with Variety and Balance Overhaul - VRO should simply overwrite some sounds from my mod.

5. Installation

  • CREATE A BACKUP OF YOUR SAVES (Just in case...)
  • Extract the files from the archive
  • Copy the "x4_sound_overhaul" folder in the "extensions" repertory located in the main game directory (where the game executable is). For example : C:\Program Files (x86)\GOG Galaxy\Games\X4 Foundations\extensions or C:\Games\Steam\steamapps\common\X4 Foundations\extensions. You'll have to create the extensions folder if you do not have one already.
  • The mod should now appear in the extensions menu of your game.
6. Uninstallation

Delete the "x4_sound_overhaul" folder from your "extensions" repertory.

7. Special Thanks

Thanks to EsoKerman on the Egosoft forums, for helping me publish the mono version quicker and ensure the compatibility of the mod with Linux and Mac.
Thanks to Shuulo for helping me fix and improve my script.
Last edited by Neloth23 on Sat, 22. Feb 20, 22:43, edited 8 times in total.

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Thu, 13. Feb 20, 20:36

Version History

1.00
  • Initial release
1.10
  • Fixed acceleration/break and engine sounds being too loud on L ships.
1.20
  • Added new travel drive activation sound for L and XL ships
  • Added new speedbar sounds
  • Improved synchronisation of travel drive sounds for L and XL ships
  • Lowered volume of ship ignition starts and stops
  • Lowered distance radius of asteroid explosion sounds
  • Switched a few ship ignition start and stop sounds
1.30
  • Added new wall fly-by sound
  • Reduced volume of repair laser impact sounds
  • Fixed several script errors
Last edited by Neloth23 on Sat, 22. Feb 20, 22:45, edited 4 times in total.

User avatar
EsoKerman
Posts: 7
Joined: Fri, 12. Apr 19, 20:57

Re: [MOD] X4 Sound Overhaul v1.00

Post by EsoKerman » Thu, 13. Feb 20, 21:49

Hello

your mod does not work on Linux and Mac. It uses uppercase in its main folder and we need to change it. As a consequence it doesn't work, since we have to change all the paths in the sound_library file.

More information here : viewtopic.php?f=180&t=414524

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Thu, 13. Feb 20, 22:08

Hello,

Sorry about that, I didn't know.

I'll try to fix this ASAP.

User avatar
EsoKerman
Posts: 7
Joined: Fri, 12. Apr 19, 20:57

Re: [MOD] X4 Sound Overhaul v1.00

Post by EsoKerman » Thu, 13. Feb 20, 22:33

Neloth23 wrote:
Thu, 13. Feb 20, 22:08
Hello,

Sorry about that, I didn't know.

I'll try to fix this ASAP.
I'm sorry too, I send a bad link.

It's here : viewtopic.php?t=380912

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Fri, 14. Feb 20, 00:01

EsoKerman wrote:
Thu, 13. Feb 20, 22:33
Neloth23 wrote:
Thu, 13. Feb 20, 22:08
Hello,

Sorry about that, I didn't know.

I'll try to fix this ASAP.
I'm sorry too, I send a bad link.

It's here : viewtopic.php?t=380912
Thanks for the new link, it helped a lot!

I just uploaded a revised version of the mod. The main folder is now called x4_sound_overhaul. I also checked the files and removed the capital letters in some sound files, just in case. It should work properly now.

Let me know how it goes!

User avatar
EsoKerman
Posts: 7
Joined: Fri, 12. Apr 19, 20:57

Re: [MOD] X4 Sound Overhaul v1.00

Post by EsoKerman » Fri, 14. Feb 20, 11:08

It works, thank you !

It's a big job and the rendering is really good, well done !

Shuulo
Posts: 813
Joined: Mon, 14. Apr 08, 17:03
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Shuulo » Fri, 14. Feb 20, 14:05

One warning to you though, X4 engine does not support Stereo sounds well, I also used some stereo in VRO before 3.0, but this led to some weird bugs with sound abruptly cutting out, unexpected loud peaks, wrong sound pitch etc. Especially for weapons with "loop" sounds like Bolt and Beam weapons.
This was also the cause of early 3.0 beta when there was a lot of "random noise" as it turned out it was due to travel mode engage was stereo and devs fixed it to be mono.
It may be a good idea to stay away form stereo sounds, but its up to you.

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Fri, 14. Feb 20, 18:31

EsoKerman wrote:
Fri, 14. Feb 20, 11:08
It works, thank you !

It's a big job and the rendering is really good, well done !
Glad to hear it!

Thanks for the kind words!

Shuulo wrote:
Fri, 14. Feb 20, 14:05
One warning to you though, X4 engine does not support Stereo sounds well, I also used some stereo in VRO before 3.0, but this led to some weird bugs with sound abruptly cutting out, unexpected loud peaks, wrong sound pitch etc. Especially for weapons with "loop" sounds like Bolt and Beam weapons.
This was also the cause of early 3.0 beta when there was a lot of "random noise" as it turned out it was due to travel mode engage was stereo and devs fixed it to be mono.
It may be a good idea to stay away form stereo sounds, but its up to you.
Thanks for the warning! As of the current beta, I noticed no such issue with my mod during testing. (I had indeed random noises in 2.60, but they have since disappeared, maybe Egosoft managed to improve the handling of stereo sound in the engine?)

That being said, if people experience sound issues, I can make an alternate version of the mod entirely in mono.

User avatar
EsoKerman
Posts: 7
Joined: Fri, 12. Apr 19, 20:57

Re: [MOD] X4 Sound Overhaul v1.00

Post by EsoKerman » Fri, 14. Feb 20, 20:57

Neloth23 wrote:
Fri, 14. Feb 20, 18:31

Thanks for the warning! As of the current beta, I noticed no such issue with my mod during testing. (I had indeed random noises in 2.60, but they have since disappeared, maybe Egosoft managed to improve the handling of stereo sound in the engine?)

That being said, if people experience sound issues, I can make an alternate version of the mod entirely in mono.
I have the feeling that sounds get mixed up, For example when i accelerate and decelerate quickly. I also had a bug, the sound of an L engine was so strong it destroyed my ears.

I put the sounds in Mono, i'll test it tomorrow. Unfortunately i can't upload them to you because of my connection, it will be faster to do it yourself.

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Fri, 14. Feb 20, 21:24

EsoKerman wrote:
Fri, 14. Feb 20, 20:57
I have the feeling that sounds get mixed up, For example when i accelerate and decelerate quickly. I also had a bug, the sound of an L engine was so strong it destroyed my ears.

I put the sounds in Mono, i'll test it tomorrow. Unfortunately i can't upload them to you because of my connection, it will be faster to do it yourself.
Sorry to hear that. I'll look into the acceleration/deceleration problem. Does it occur when you use travel mode, or just regular acceleration/deceleration?

For the L engine, is it the acceleration and deceleration sounds that caused the issue? I checked and they are indeed way too loud. My apologies for missing that. I'll post a corrected build for this.

I'll start working on a mono version of the mod. However, I'll need to tweak the mix a bit so it might take a little while before it is available.

User avatar
EsoKerman
Posts: 7
Joined: Fri, 12. Apr 19, 20:57

Re: [MOD] X4 Sound Overhaul v1.00

Post by EsoKerman » Fri, 14. Feb 20, 21:51

Neloth23 wrote:
Fri, 14. Feb 20, 21:24
Sorry to hear that. I'll look into the acceleration/deceleration problem. Does it occur when you use travel mode, or just regular acceleration/deceleration?

For the L engine, is it the acceleration and deceleration sounds that caused the issue? I checked and they are indeed way too loud. My apologies for missing that. I'll post a corrected build for this.

I'll start working on a mono version of the mod. However, I'll need to tweak the mix a bit so it might take a little while before it is available.
Indeed, i was not precise enough. This happens when i activate and deactivate the travel engine. I tested in mono and it's better. At least that's the feeling i'm getting.

Neloth23
Posts: 28
Joined: Thu, 13. Jul 17, 18:31
x4

Re: [MOD] X4 Sound Overhaul v1.00

Post by Neloth23 » Fri, 14. Feb 20, 22:56

EsoKerman wrote:
Fri, 14. Feb 20, 21:51
Indeed, i was not precise enough. This happens when i activate and deactivate the travel engine. I tested in mono and it's better. At least that's the feeling i'm getting.
I ran a few tests on the travel mode, on S and L ships. What I can hear is that the activation sound overlaps with the deactivation effect if I cut the travel mode quickly. This problem is caused by the fact that I used long sound effects (between 5 and 10 seconds). I liked those sounds that way (I rarely cut the travel drive that quickly), but I can cut them to improve things, if it corresponds to the issue you experienced.

I'm also uploading a new version of the mod, which should hopefully correct the L engine issues. Let me know if it sounds better on your end.

I'll start working on the mono version this weekend. I'll try to publish it ASAP.

User avatar
Misunderstood Wookie
Posts: 334
Joined: Mon, 15. Mar 04, 09:07
x4

Re: [MOD] X4 Sound Overhaul v1.10

Post by Misunderstood Wookie » Sat, 15. Feb 20, 03:40

I am going to follow his here to try out later today nice work, but yeah stereo sound can be a bit so so in this game. What you could do is introduce extra length to the sound but not add any sound it would just be extra time to the end of the sound file.
*modified*
MOD Aspiring Freelancer GameStart
MOD Variety and Rebalance Overhaul Icon Pack
I lost my Hans and should not be flying Solo.
Image

tomchk
Posts: 734
Joined: Mon, 26. Jan 15, 20:55
x4

Re: [MOD] X4 Sound Overhaul v1.10

Post by tomchk » Sat, 15. Feb 20, 08:34

Good call switching to mono!

Post Reply

Return to “X4: Foundations - Scripts and Modding”