Low fps

Ask here if you experience technical problems with X4: Foundations.

Moderator: Moderators for English X Forum

Post Reply
Eris Indignant
Posts: 2
Joined: Wed, 27. Nov 19, 23:37

Low fps

Post by Eris Indignant » Mon, 2. Dec 19, 23:58

I'm playing on a 1070 with an i7-6700 on a laptop. Fps is fine in space except for asteroid fields and drops to around 25 in most stations. This happens even when I drop everything to low with the resolution at 720. I've forced it to recognize my card in Nvidia control panel and it plays the same regardless, also wether on 2.6 or 3.0 beta. I've verified the game files as well and I'm not running any mods. Anyone have any ideas?

Imperial Good
Posts: 974
Joined: Fri, 21. Dec 18, 19:23
x4

Re: Low fps

Post by Imperial Good » Tue, 3. Dec 19, 01:30

Make sure your CPU is keeping 4 GHz sustained. X4 is very single thread hungry.

Eris Indignant
Posts: 2
Joined: Wed, 27. Nov 19, 23:37

Re: Low fps

Post by Eris Indignant » Tue, 3. Dec 19, 03:41

Cpu only does 3.3 max. It's only at 20-30% when I play

Rastuasi
Posts: 118
Joined: Mon, 1. Oct 18, 16:28
x4

Re: Low fps

Post by Rastuasi » Wed, 4. Dec 19, 17:58

Total CPU usage means nothing, the speed isn't the same as capacity. When you have a 6 lane highway packed with traffic usually moving at 75 mph, but then force all traffic into two lanes and limit that speed to 55 mph, it slows the ability for a car to get fully through rapidly. So in this case, you have calls being held up waiting on the CPU to run it.

Post Reply

Return to “X4: Foundations - Technical Support”