[MOD] Miscellaneous IZ Combat Tweaks

The place to discuss scripting and game modifications for X Rebirth.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

rafezetter
Posts: 130
Joined: Wed, 25. Jul 07, 22:00
x3

Post by rafezetter » Sat, 14. Apr 18, 20:40

Hmm - yonder you altered the Move.escort.capital.xml - but that that file for me is now empty since the introduction of supplemental 2 - and the code is different and I don't know nearly enough to know what to look for.

right now to get them all to act I'm having to have them all in my squad and use "squad attack" from another mod - it's incredibly clunky and awful when it's over 20 ships in my fleet.

It's so bad and annoying it's made me stop playing until today, and I had to deal with it again which reminded me of this post.

W.Evans when you have the time, could you take a look at what his fix says and tell me where to put it please?



Edit after some big battles tonite I've noticed a few things:

Balors firing in all directions instead of keeping thier nose pointed at the intended target before firing, thus their missile salvo's missing quite often or being essentially worthless because the missiles take so long re-orientate to the target, it's been destroyed.

Even with all cap ships being under my direct squad instead of escorting (because something is wrong with the escort.move commands) they boost instead of jump when I am OOZ - but make correction jumps for IZ combat as normal, they have plenty of fuel.

This means my Balors being the fastest always get there first, they are also the weakest and thus I've lost several taking on Xenon I.

I'm now having to micromanage the move commands of a large fleet of 18 ships ONE BY ONE and do them in order of speed.

This is not fun, it feels like I've taken on the task of what your mod says it does (I re-read the nexus page and the info for the supplements just to make sure I had my info straight), so I've quit the game, writing this and now I'm going to play something else until you've had a chance to reply.

In just tonites couple of hours Xenon hunting I noticed several Balors having a major derp. When enacting the boost away evasion, but were pointing AT the xenon I's, they just rammed right into them instead of turning, THEN boosting AWAY, 1 died from the I's turrets fire, the other 2 just bounced off the hull, then turned a bit and boosted..... but they didn't turn very much so they both just skimmed past.

1 got killed when it then rammed one of my titurels while still close to the Xenon I, the other made it away.

ALL THREE ARE ELITE CREWS - because I mark all my ships that have elite crews - so thus this behaviour was done under the MICT scripts.

I've seen others of my ships do it too, but Balors are squishy enough for it to be a problem.

I've cheated back in some Balors to compensate for the annoyance - I'd rather not have to.

I'm not using any other mod that might interfere with MICT - I removed CDOai mod as it had bugged out my storyline - the bit attacking the drone fab and the exodus of HoA ships to devries.

Oh yeah - "captains locking onto a hostile and chasing them until its destroyed..."

can you tell me how to disable that? I've lost several more cap ships like titurels who've locked on to ships with more firepower and hull strength than themselves and got themselves killed.

I'm guessing there's no way to have some sort of combat check along the lines of "can I actually win this fight", before chasing an enemy capship away from the main fleet.

Re-engaging after being badly damaged is an exercise in futility.

I'm sorry this post comes across a bit harsh and accusatory, but the last few hours were not what I'd call enjoyable.

Using my fleet against a few weaker targets there was no issues, but now I'm taking on Xenon ships and some places might have 4 or 5 with a couple of I's, the micromanagement required to keep them alive is just putting me right off playing.

Quite a lot of that is down to the movements not working as what I assumed was intended.

I would really appreciate any help you might be able to give so having a fleet large enough to invade Xenon areas doesn't continue to be a micro management PITA.[/u]

Yonder
Posts: 311
Joined: Wed, 24. Mar 04, 23:53
x3

Post by Yonder » Sat, 21. Apr 18, 03:00

Sorry I missed this. My post back on the 8th is the entire replacement file. If you copy it and paste it so that move.escort.capital.xml is exactly equal to what I've posted you should be fine.

Greg_G
Posts: 110
Joined: Tue, 26. Apr 05, 19:15
xr

Post by Greg_G » Sat, 30. Jun 18, 02:21

I just wanted to report a strange issue I just had. I'm generally of the opinion I reap what I sow because I run a significant number of mods, so I'm not really seeking assistance. But in case others run into this in the future, I felt it was good to report it.

About 48 hours into this play-through, which hasn't had any form of crash or lock-up, I decided to install MICT with supplements 3 and 8. I enjoyed using it for about 6 hours before my troubles began. I decided at one point to reload a save I'd made a few minutes before. It loaded fine, but after 10-15 seconds the game would just freeze and require an end task. So I tried a save from 15 minutes before, same thing. I tried another save 30 minutes before which was in a different sector, same thing again. I tried this about 8 times. Every time the game froze after 10-15 seconds of loading.

So I disabled MICT, since it was the most recent addition, and was able to load and play any of these saves without issue, giving each load a good 2 minutes to feel confident in this. I then re-enabled it, and tried the same saves, and the freezes resumed, same MO.

Next I disabled MICT, restarted, loaded and immediately saved my game, re-enabled MICT, restarted and then loaded that newest save. It loaded fine and had no freeze after 10 minutes of play. I then tried loading one of the saves that didn't have this disable-resave-enable treatment, and the freeze happened. I then restarted and once again loaded my new save, which got that treatment, and it continues to play just fine.

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sat, 30. Jun 18, 13:47

@Greg_G, thanks for the report. Could you post a link to the save that freezes? Can't test it right now since i unfortunately still don't have a PC that can run the game, but would like to take a look at the file and test when able.

Could you also post a list of mods you have installed? Could come in handy to check for conflicts.

And just so it's clear, you got base MICT from the Nexus with just supplements 3 and 8, no MOCT? Would help narrow down the problem.

Greg_G
Posts: 110
Joined: Tue, 26. Apr 05, 19:15
xr

Post by Greg_G » Sat, 30. Jun 18, 22:19

@w.evans: I'd be happy to do so. I just hope I'm not wasting your time with something I managed to muck up that no one else ever sees. :)

The linked 7z file contains two saves that exhibit the problem (saves 3 and 4) and one from after I worked around it using the steps above (save 6):
https://secure.lumacs.org/nc/index.php/ ... XcYYm9pPfB

I do indeed run MOCT as well, although that one has been in since the beginning of this playthrough. My mod list:

Code: Select all

alexalsp_ya_crewfixonfired
AutoCrew
AutoLooter
autoresupply
AutoTrain
avoidfoo
BetterStationScanMode
CombatRankBailout
do_not_shoot_non-combat_drones
ego_dlc_2
ego_dlc_teladi_outpost
emy_gmsc
improved_log
loltak_ICIM_V401_St
marinerebalance
mej_improved_object_menu
minigame_hack
MoreCrew
nidaren_titurel_engine_fix
NoSteeringModeNotification
no_killtarget_in_xenon_space
npcsgainxp
remove_tips_from_the_log
shiprecycle
shortname_generator
show resources
Show Skills
showmeyourfactionplease
sidebarextender
simooms_galactic_dress_code
simooms_lantern
skunkengineer
trade menu cargo hold filter
utcac_ext_advanced_renaming
utcac_ext_advanced_renaming_user
UTCommandAndControl-master
w.e_betterautoaim
w.e_diffhack
w.e_engineerdronefix
w.e_mict
w.e_moc-t
w.e_TradeRelations
yat2
yorricksyisha
Almost all are known 4.30 compatible, and those very few that aren't have run well for me so far (with the exception of Simoom's Lantern for which I only use one function which does still work fine). All have been in without noticeable issue for at least 24 hours of play-time. Note that I run the GOG version of X:R.

Obviously I'm a fan of your mods, and thank you for them. :)

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sat, 30. Jun 18, 23:07

Thanks much for the saves.

Symptoms sound like an infinite loop. Disabling the mod, loading a save, then saving it again effectively clears the mod logic out, then reinstalling reintroduces it. That it happens a variable amount of time after the mod has been running suggests one of the added features, possibly the engineer stuff (supplement 8 ), probably in conjunction with one of the other mods on the list since no one has reported freezes before (that i can remember, at least).

Would you happen to remember if there were any battles happening in your immediate vicinity at the moment the freezes happen? i don't think it's the combat scripts, but would be good to rule them out since they form the bulk of the mod.

Since an infinite loop is a possibility, would strongly suggest that you go without MICT for now, at least until i can pinpoint where the problem is and give the all clear.

And my apologies again if this takes long. Can't run the game so can't test. i can still troubleshoot by logic gaming, but that can take a long time unless i'm lucky and happen to look at the right spots first try (which does happen from time to time, but yeah, luck is fickle).

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sat, 30. Jun 18, 23:12

Actually, wait a sec. Could you please try the game without supp 8? With the setup you described, just delete \w.e_mict\aiscripts\engineer.ai.xml

Greg_G
Posts: 110
Joined: Tue, 26. Apr 05, 19:15
xr

Post by Greg_G » Sun, 1. Jul 18, 00:18

I deleted \w.e_mict\aiscripts\engineer.ai.xml and started X:R and loaded one of the problematic saves (save 3) and it still froze up, unfortunately.
w.evans wrote:Thanks much for the saves.
I'm happy to help.
w.evans wrote:That it happens a variable amount of time after the mod has been running suggests one of the added features
My perception is that it's somewhat variable, but my perceptions may be flawed. And I perceive that the amount of time is the same for the same save, just variable between multiple saves. If it would be of value I could time it.
w.evans wrote:since no one has reported freezes before (that i can remember, at least).
Aye, I didn't see any such reports, which was why I figured it was my personal Frankenstein's creature of mods. :) Abby...Normal!
w.evans wrote:Would you happen to remember if there were any battles happening in your immediate vicinity at the moment the freezes happen?
At least one of them (save 3) seems to have no hostilities at all nearby.
w.evans wrote:Since an infinite loop is a possibility, would strongly suggest that you go without MICT for now, at least until i can pinpoint where the problem is and give the all clear.
But... I like it. ;) I did debate, after "fixing" my save, whether I should just continue without MICT or stick with it. Risking it won the day. I was pretty much sold the first time I called in my three Titurels on an enemy Heavy Sul, pop pop pop pew pew kaboom. :)

I know there's risk in my choice, but I'm thinking if it happens again then I'll let you know, and if it doesn't just hope it was a rare fluke. But if you'd like me to try other things I can do so.

Edit:I'm not sure if it's informative at all, but I thought I'd check out CPU usage. During normal play X:R runs between 50-70% across the four CPU threads. When the freeze happens X:R runs around 25% across the four CPU threads.

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sun, 1. Jul 18, 00:46

Hurr. Then not the engineer script. Hm. Alright, thanks. Think i'll risk it and try firing up the game on this machine to see what i could gather before it freezes since the game won't have to run for long. Shouldn't go kaboom just yet.

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sun, 1. Jul 18, 01:31

Progress! Of a sort. It wasn't an NPC ship. But CPU topped off at 97 C that last run and the discrete graphics card didn't run at all so think that's about it for tonight. Will try again when things have cooled down a bit.

Greg_G
Posts: 110
Joined: Tue, 26. Apr 05, 19:15
xr

Post by Greg_G » Sun, 1. Jul 18, 02:09

Hehe yikes! A bit toasty. :) Were you able to reproduce the freeze (script triggered not CPU inferno triggered) though? If so that's a pretty significant step.

Edit:Fixed typo that changed the meaning of what I was trying to say.

w.evans
Posts: 2962
Joined: Tue, 18. Nov 14, 17:23
x4

Post by w.evans » Sun, 1. Jul 18, 10:16

Yup. Game froze while every single NPC ship was destroyed, so couldn't be scripts running on them. Positive wasn't the CPU. Now, just have to figure out what your ships were doing and where it tripped.

Ovni
Posts: 116
Joined: Sun, 6. May 12, 23:42
xr

Re:

Post by Ovni » Thu, 29. Nov 18, 06:24

w.evans wrote:
Sun, 1. Jul 18, 10:16
Yup. Game froze while every single NPC ship was destroyed, so couldn't be scripts running on them. Positive wasn't the CPU. Now, just have to figure out what your ships were doing and where it tripped.
Did you ever find a solution to the problem? Sorry to resurrect the thread 4 months later, but I was hoping to use this in my X Rebirth playthrough while I wait for the first reviews/reports of whether X4 is good.

Post Reply

Return to “X Rebirth - Scripts and Modding”