Linux support thread

Ask here if you experience technical problems with X Rebirth.

Moderator: Moderators for English X Forum

Post Reply
timon37
EGOSOFT
EGOSOFT
Posts: 370
Joined: Fri, 14. Dec 12, 12:02
x4

Post by timon37 » Fri, 13. Mar 15, 15:03

hhr wrote:- launched a campaign from the beginning. phrases in the dialogues have very large and noticeable pause.
You'll also probably have really bad performance. This could happen if for some reason openal wasn't reading the attached config file properly. Can you try running "steam -console" from the terminal and see what you get? There'll probably be a lot of AL_OUT_OF_MEMORY errors.
YorrickVander wrote:Btw the linux loading screen is much cooler then the current windows one. Copy it over?
NO! It reflects the relative coolness between linux and anything else;p

hhr
Posts: 59
Joined: Fri, 6. Oct 06, 15:18
x4

Post by hhr » Fri, 13. Mar 15, 15:49

i have a lot of "ShaderD3D::SetTechniqueByName() shader shadergl\high_spec\xu_ssao techinque SSAOPOST" in the log ;) but no OAL errors: https://gist.github.com/hhrhhr/818bf3f8e96d96530dea

I honestly do not know how to record video of the game and Steam Broadcasting in Linux does not work. I can record directly from the screen, if necessary.

timon37
EGOSOFT
EGOSOFT
Posts: 370
Joined: Fri, 14. Dec 12, 12:02
x4

Post by timon37 » Fri, 13. Mar 15, 16:12

@hhr Did you start the campaign?
The errors will only happen when there's enough sound instances, and that's when you should also get the delays.

The log looks fine, though you might want to disable ssao since it won't work either way and could cause issues.

rboerdijk
EGOSOFT
EGOSOFT
Posts: 1214
Joined: Fri, 11. Jan 13, 15:26
x4

Post by rboerdijk » Fri, 13. Mar 15, 17:04

fallenwizard wrote:Build 1

-----------------------------------------------------------------

Zone: Crimson Rocks

Pink background
Screenshot

(Seems to happen to most zones in DeVries. Maybe the sun shader is at fault?)

-----------------------------------------------------------------
Thanks for the report - I teleported around quite a bit looking for "pink stuff", but managed to miss that zone.
Just committed a fix - it will be included in the next linux-update.

hhr
Posts: 59
Joined: Fri, 6. Oct 06, 15:18
x4

Post by hhr » Fri, 13. Mar 15, 17:10

timon37 wrote:@hhr Did you start the campaign?
no, this log was from save.

I set minimum settings, errors in the log has really become a lot less. but pauses between sentences remained.

I also think I know what the problem is. in the German dubbing subtitles do not always have time for a voice even in windows-version. phrase has ended, but the subtitles continue to show another second or two. this is happening in the story dialogues.

the English voice acting is not a problem. in general, this does not apply to the Linux-version ;)

fallenwizard
Posts: 608
Joined: Tue, 13. Apr 10, 20:03
x4

Post by fallenwizard » Fri, 13. Mar 15, 17:21

Another bug:

Using highways and superhighways makes the radar content shake back and forth.

(You guys need to create a bug tracker. Posting everything into this thread makes it a mess.)


------------------------------

Graphical glitch at the window borders while using a highway/super highway:

Screenshot

timon37
EGOSOFT
EGOSOFT
Posts: 370
Joined: Fri, 14. Dec 12, 12:02
x4

Post by timon37 » Fri, 13. Mar 15, 17:38

We most likely will setup a bug tracker (I hope).

fallenwizard
Posts: 608
Joined: Tue, 13. Apr 10, 20:03
x4

Post by fallenwizard » Fri, 13. Mar 15, 17:48

Page up/Page down doesn't work in menus.

--------------------

You can't type anything into text fields. No matter if you try to rename ships, sectors or use filters.

--------------------

Long range scanner sound doesn't change in pitch while trying to use it.

---------------------

Endless sound loop after using the container magnet


EDIT:
Build 2:

@rboerdijk
Pink background is still there in DeVries -> Bleak Pebble -> Crimson Rocks
Screenshot
Save game

timon37
EGOSOFT
EGOSOFT
Posts: 370
Joined: Fri, 14. Dec 12, 12:02
x4

Post by timon37 » Fri, 13. Mar 15, 20:42

Hmmm that's probably my screw-up.

pete910
Posts: 8
Joined: Sun, 10. May 09, 16:18

Post by pete910 » Fri, 13. Mar 15, 22:11

timon37 wrote:Hmmm that's probably my screw-up.
Lol, at least your honest !

xarses
Posts: 2
Joined: Sat, 17. Jan 04, 06:29
x4

Post by xarses » Sat, 14. Mar 15, 03:17

xarses wrote:Debian Sid

http://pasteboard.co/1LEYbu7E.png

Code: Select all

./XRebirth 
Elephant Memory Manager Initialized with 0MB
Elephant Memory Manager Name And Callstack Base Address is 0x123b0f1
Elephant Memory Manager Mode: Resizable Mode, Has small heap: No, 64bit, Version: 1.7.1
Heap Resize Generic 0x0x7fba32398000 to 0x0x7fba3c397fc0 freeusable 167772160
szCmd: /bin/sh -c '"/home/andreww/.local/share/Steam/steam.sh" "steam://run/2870"' &
Segmentation fault
andreww@aw-linux:~/SteamApps/X Rebirth$ Running Steam on debian 8 64-bit
STEAM_RUNTIME is enabled automatically
Video driver is nouveau
full log http://paste.openstack.org/show/2adSFQ4VfHnFZnTCqT3L/

fallenwizard
Posts: 608
Joined: Tue, 13. Apr 10, 20:03
x4

Post by fallenwizard » Sat, 14. Mar 15, 03:19

xarses wrote:
xarses wrote:Debian Sid

http://pasteboard.co/1LEYbu7E.png

Code: Select all

./XRebirth 
Elephant Memory Manager Initialized with 0MB
Elephant Memory Manager Name And Callstack Base Address is 0x123b0f1
Elephant Memory Manager Mode: Resizable Mode, Has small heap: No, 64bit, Version: 1.7.1
Heap Resize Generic 0x0x7fba32398000 to 0x0x7fba3c397fc0 freeusable 167772160
szCmd: /bin/sh -c '"/home/andreww/.local/share/Steam/steam.sh" "steam://run/2870"' &
Segmentation fault
andreww@aw-linux:~/SteamApps/X Rebirth$ Running Steam on debian 8 64-bit
STEAM_RUNTIME is enabled automatically
Video driver is nouveau
full log http://paste.openstack.org/show/2adSFQ4VfHnFZnTCqT3L/
timon37 wrote:Also I didn't test nouveau, but it's quite likely not to work, even with fairly new mesa. I do hope to properly support the open-source drivers (for now I just tried not to use too many extensions above 3.3) but for now there are more important priorities.

Gazzonyx
Posts: 6
Joined: Tue, 10. Jul 07, 04:48
x3

Post by Gazzonyx » Sat, 14. Mar 15, 07:14

First off, thank you so much for a Linux port. I've been holding on X Rebirth anxiously waiting and hoping this day would come. This really made my week.

Now, with that being said...
No joystick support yet. It just feels wrong. I was hoping to dig around and get lucky if I just created an inputmap.xml, but I'm actually pretty burnt from debugging my own code all week and I've got a hunch that there isn't an interface to the SDL libs just yet.

Is there a hack to enable, even if buggy, basic joystick support? If not, as I suspect is the case, is there a timeline for when that support can be expected? I'd like to formally volunteer to test that piece of code as soon as it compiles. :)


FWIW, I'm running KDE on:
* Ubuntu 14.04
- kernel: 3.13.0-24-generic #46-Ubuntu SMP
* Geforce GT 730
- binary blob: nvidia-331, 331.113, 3.13.0-24-generic, x86_64
and I haven't had any other issues with X Rebirth in the short time I've played with it.

User avatar
aspbazi
Posts: 11
Joined: Sat, 7. Nov 09, 02:18
x4

Post by aspbazi » Sat, 14. Mar 15, 11:34

Thank you so much for a Linux port.

Test...

- Intel® Core™ i5 3.00 - 2320 x4
- DDR3 - 16GB (Dual).
- openSUSE 13.2 x-86_64.
- Kernel 3.16
- Nvidia GTX-650 ddr5 1024 mb / 128 bit.
- Drivers 346.35
- Display resolution 1920x1080 (HDMI)

$ ldd XRebirth

linux-vdso.so.1 (0x00007fff601d5000)
libavformat.so.55 => lib/libavformat.so.55 (0x00007f4b3c7c3000)
libavcodec.so.55 => lib/libavcodec.so.55 (0x00007f4b3bb39000)
libswscale.so.2 => lib/libswscale.so.2 (0x00007f4b3b8d8000)
libavutil.so.52 => lib/libavutil.so.52 (0x00007f4b3b696000)
libxml2.so.2 => lib/libxml2.so.2 (0x00007f4b3b339000)
libSDL2-2.0.so.0 => lib/libSDL2-2.0.so.0 (0x00007f4b3b03e000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f4b3adf7000)
libSDL2_image-2.0.so.0 => lib/libSDL2_image-2.0.so.0 (0x00007f4b3abd1000)
libopenal.so.1 => lib/libopenal.so.1 (0x00007f4b3a968000)
libvorbisfile.so.3 => lib/libvorbisfile.so.3 (0x00007f4b3a760000)
libm.so.6 => /lib64/libm.so.6 (0x00007f4b3a45e000)
libswresample.so.0 => lib/libswresample.so.0 (0x00007f4b3a246000)
libsteam_api.so => lib/libsteam_api.so (0x00007f4b3a033000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f4b39d2a000)
libz.so.1 => /lib64/libz.so.1 (0x00007f4b39b14000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f4b39910000)
libluajit-5.1.so.2 => lib/libluajit-5.1.so.2 (0x00007f4b3969f000)
libboost_regex.so.1.51.0 => lib/libboost_regex.so.1.51.0 (0x00007f4b393ba000)
libboost_filesystem.so.1.51.0 => lib/libboost_filesystem.so.1.51.0 (0x00007f4b391a2000)
libboost_system.so.1.51.0 => lib/libboost_system.so.1.51.0 (0x00007f4b38f9e000)
libGLEW.so.1.10 => lib/libGLEW.so.1.10 (0x00007f4b38d28000)
libGL.so.1 => /usr/X11R6/lib64/libGL.so.1 (0x00007f4b389cf000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f4b387b8000)
libc.so.6 => /lib64/libc.so.6 (0x00007f4b38411000)
librt.so.1 => /lib64/librt.so.1 (0x00007f4b38208000)
libbz2.so.1.0 => not found
libva.so.1 => lib/libva.so.1 (0x00007f4b37ff3000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4b3cadc000)
libvorbis.so.0 => lib/libvorbis.so.0 (0x00007f4b37dc6000)
libogg.so.0 => lib/libogg.so.0 (0x00007f4b37bbf000)
libnvidia-tls.so.346.35 => /usr/lib64/tls/libnvidia-tls.so.346.35 (0x00007f4b379bb000)
libnvidia-glcore.so.346.35 => /usr/lib64/libnvidia-glcore.so.346.35 (0x00007f4b34ce3000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f4b349a5000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f4b34792000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f4b34572000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f4b3436d000)


Edit: removed the spoiler tags, as they just hide the text, which is not really needed here. X2-Illuminatus
IT-Service «Crimea-Karro» .

timon37
EGOSOFT
EGOSOFT
Posts: 370
Joined: Fri, 14. Dec 12, 12:02
x4

Post by timon37 » Sat, 14. Mar 15, 12:18

@xarses

Yeah I'm afraid your mesa doesn't support glsl 3.3 at all, so there isn't much I can do about that, at least not in the short term. I'm not sure what nouveau's status is, there might be an experimental repository for your distro with newer mesa which could have opengl 3.3, which may work. But that's a lot of ifs. Alternative is of course to install the "evil" nvidia proprietary driver.

Btw sorry for the bad error reporting, but implementing stuff had higher priority.

@Gazzonyx

Yeah it's not implemented. Sorry but I don't have a timeline. Especially since the input stuff can be a bit tricky, although it looks a lot less ridiculous than what was in X3;)

@aspbazi

Hmm that's peculiar. Though it's likely that's not the issue (afaik steam-rt should have libbz2 but you won't see it with ldd since the LD_LIBRARY_PATH isn't set), try running "steam -console" from the terminal to get the log of what's happening.

Post Reply

Return to “X Rebirth - Technical Support”